BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

Sat Jun 16, 2018 12:06 pm: The BOB server was upgraded (O/S and database) today. If you encounter any errors, please post on the board. Posting has been tested and seems to be working. Thanks.
General Notice: Upcoming Events: BI & HANA 2018 Prague: Jun 29.

Could not get page number (Error: RWI 00223)
2 members found this topic helpful

 
Search this topic... | Search SDK (VBA/ASP/JSP)... | Search Box
Register or Login to Post    Forum Index -> SDK (VBA/ASP/JSP)  Previous TopicPrint TopicNext Topic
Author Message
paul182
Forum Member
Forum Member



Joined: 09 Aug 2007

Posts: 5



PostPosted: Thu Aug 09, 2007 7:11 am 
Post subject: Could not get page number (Error: RWI 00223)

I am using Business Objects XI R2 with SP2.

I am getting the error:
com.businessobjects.rebean.wi.CommunicationException: Could not get page number. (Error: RWI 00223)

When the openDocument is called.
DocumentInstance doc = ReportEngine.openDocument(docId);

I have some previous threads and have tried the following:
1. Restarting all the BO servers
2. Setting the MAX_HEAP_SIZE in Tomcat.

Both of these do not seem to work. Can anyone provide me with a solution?
Back to top
paulfischer
Senior Member
Senior Member



Joined: 08 Sep 2002

Posts: 47
Location: Virginia


flag
PostPosted: Thu Aug 09, 2007 8:32 am 
Post subject: Re: Could not get page number (Error: RWI 00223)

I had the same error the other day when building a class that calls: (XMLView)report.getView(OutputFormatType.XML)

After many frustrating hours, I copied all the .jar files from the JSP Example I was using from the BO Developer library to my WEB-INF/lib directory, and the error went away. So apparently, I had a missing or incorrect library file.
Back to top
paul182
Forum Member
Forum Member



Joined: 09 Aug 2007

Posts: 5



PostPosted: Sun Aug 12, 2007 11:28 pm 
Post subject: Re: Could not get page number (Error: RWI 00223)

Thanks a lot. The above solution worked fine.

I had started building my application on the sample code available with BO documentation. Obviously those samples were using the jars prior to SP1/SP2. Once I replaced the jars in my project with the ones from BO installation, it started working fine.
Back to top
beautifulgirl
Forum Member
Forum Member



Joined: 27 Jul 2007

Posts: 20



PostPosted: Mon Oct 08, 2007 11:11 pm 
Post subject: Re: Could not get page number (Error: RWI 00223)

paulfischer wrote:
I had the same error the other day when building a class that calls: (XMLView)report.getView(OutputFormatType.XML)

After many frustrating hours, I copied all the .jar files from the JSP Example I was using from the BO Developer library to my WEB-INF/lib directory, and the error went away. So apparently, I had a missing or incorrect library file.


Where to find BO Developer library? Thanks
-V
Back to top
paul182
Forum Member
Forum Member



Joined: 09 Aug 2007

Posts: 5



PostPosted: Mon Oct 08, 2007 11:36 pm 
Post subject: Re: Could not get page number (Error: RWI 00223)

If you are looking for the jar files, you will get it from your BO installation:

In my installation the path is:
D:\Program Files\Business Objects\common\3.5\java\lib
Back to top
beautifulgirl
Forum Member
Forum Member



Joined: 27 Jul 2007

Posts: 20



PostPosted: Mon Oct 08, 2007 11:45 pm 
Post subject: Re: Could not get page number (Error: RWI 00223)

paul182 wrote:
If you are looking for the jar files, you will get it from your BO installation:

In my installation the path is:
D:\Program Files\Business Objects\common\3.5\java\lib


Thank you so much Paul! but where to replace these files as I am getting the same error while opening the Webi report. I am new to BO XI R2 SP2.
I appreciate any help! yesnod.gif
-V
Back to top
paul182
Forum Member
Forum Member



Joined: 09 Aug 2007

Posts: 5



PostPosted: Tue Oct 09, 2007 6:20 am 
Post subject: Re: Could not get page number (Error: RWI 00223)

You have to replace the jars in the WEB-INF/lib of your web application.
The error maybe because the jars in your application is of an older version
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> SDK (VBA/ASP/JSP)  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0123 seconds using 17 queries. (SQL 0.0028 Parse 0.0003 Other 0.0093)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo