BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Follow BOB on Twitter! 
Follow BOB on Twitter! (Opens a new window)  

General Notice: Upcoming Events: SAP TechEd: Sep 28.

Mysterious "Not Supported" error


 
Search this topic... | Search Crystal Reports... | Search Box
Register or Login to Post    Forum Index -> Building Reports -> Crystal Reports  Previous TopicPrint TopicNext Topic
Author Message
greenmtnsun
Forum Member
Forum Member



Joined: 28 Jul 2006

Posts: 5



PostPosted: Tue Aug 08, 2006 12:05 pm 
Post subject: Mysterious "Not Supported" error

I have the strangest error message.

I brought this report from Crystal 8 that someone else wrote and opened it in Crystal 11. It wouldn't run and gave me an error message: "Not Supported" It stops part-way through data collection and says Not Supported, with one of those irritating [OK] boxes.

NO OTHER DESCRIPTION OF THE PROBLEM IS PROVIDED. Also, when I close the report, I get the message Font still in use

(Background info: Running XP locally, MS 2003 server for the DB operating system, XI Crystal developer edition with MS SQL 2005 database using Microsoft SQL Server ODBC Driver Version 03.85.1117 Driver. I had also tried the Microsoft SQL Native Client Version 09.00.2047 driver but that gave the same error. I am now less inclined to believe this is because it was using native SQL or because it needed ODBC. Its now using ODBC and failing; it once used native and failed as well.

I've done a lot of problem solving, and followed some suggestions on the net that I've seen, even though they are limited and not specific to my problem. In case one is about to suggest these steps here they are... I checked that no fields had spaces in their names from the DB, and there are no UDF's in the select statement. The entire report uses times new roman font. From what I can tell I do not have any "WhileReadingRecords" formulas and went through each formula. I've gone through the suggestions from cr_xi_designer_migration.pdf and xir2_cr_usergde_en.pdf as well.

I could really use some help. Any suggestions?
Back to top
LANFIELD
Principal Member
Principal Member



Joined: 18 May 2006
ASUG Icon
Posts: 495
Location: SIMI VALLEY, CA


flag
PostPosted: Wed Aug 09, 2006 10:42 am 
Post subject: Re: Mysterious "Not Supported" error

maybe its a query file based report and you will need that file. the query file reports arent supported in v11 there is a tool to convert them
Back to top
charlottecraig
Senior Member
Senior Member



Joined: 20 Jun 2006

Posts: 84



PostPosted: Wed Aug 09, 2006 11:40 am 
Post subject: Re: Mysterious "Not Supported" error

Back then you could base a report off of what was then called InfoViews (meta layer like Business Views) and off of a Crystal Query. those tools no longer exist so my guess is it's based on one of those?
Back to top
greenmtnsun
Forum Member
Forum Member



Joined: 28 Jul 2006

Posts: 5



PostPosted: Wed Aug 09, 2006 11:53 am 
Post subject: Re: Mysterious "Not Supported" error

The report is not a query file based report and no infoviews. I don't think there is anything to convert like that. I've looked over the report definition file pretty closely and all of things you would think of that could need to be changed are not there. I think its something else.
Back to top
charlottecraig
Senior Member
Senior Member



Joined: 20 Jun 2006

Posts: 84



PostPosted: Wed Aug 09, 2006 12:04 pm 
Post subject: Re: Mysterious "Not Supported" error

Database Driver? Are you using ODBC? Can you test the connection? Can you create a new report on it? Can you browse any data fields?
Back to top
greenmtnsun
Forum Member
Forum Member



Joined: 28 Jul 2006

Posts: 5



PostPosted: Wed Aug 09, 2006 12:27 pm 
Post subject: Re: Mysterious "Not Supported" error

Database Driver? Are you using ODBC? Can you test the connection? Can you create a new report on it? Can you browse any data fields?


ODBC. Microsoft SQL Server ODBC Driver Version 03.85.1117
I've tried a native SQL odbc driver and the OLE DB (ADO) with the SQL Server OLE DB driver as well.

Yes I can test the connection. I've used BO's special query tool to check the data as well. (SQLCon32)
I can create simple reports that hit this Database.
I can browse data fields.

Other steps taken:
1. I can't find whilereadingrecords.
2. I can't find any subreports in the report definition file.
3. I can't find any SQL expressions.
4. I've verified the database in XI.
5. I'm also able to connect to other DSNs.

Any other ideas?
Back to top
charlottecraig
Senior Member
Senior Member



Joined: 20 Jun 2006

Posts: 84



PostPosted: Wed Aug 09, 2006 12:35 pm 
Post subject: Re: Mysterious "Not Supported" error

May be corrupt, if you export to a Crystal Report sometimes that will fix it if it is corrupt. If that doesn't work, I'd create a new report and start copying and pasting from the old report to the new one - you may never see the error again but if you add things one at a time if there is a problem in the report, you'll find it. Sometimes that's all you can do
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Building Reports -> Crystal Reports  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0114 seconds using 17 queries. (SQL 0.0032 Parse 0.0002 Other 0.0080)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo