BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Sunset Ride 
Sunset Ride 

General Notice: BOB is going to retire...please see details here. All BOB forums have been converted to "read only" as of September 1st.
General Notice: No events within the next 45 days.

[BI 4.x] [XI 4.2] Missing JDK folder


 
Search this topic... | Search XI Server Discussion... | Search Box
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Author Message
mike nagel
Senior Member
Senior Member



Joined: 18 Apr 2005

Posts: 77



PostPosted: Mon Nov 26, 2018 9:21 am 
Post subject: [XI 4.2] Missing JDK folder

I'm in the process of setting up SSO on XI4.2, and while following the excellent instructions provided by Josh here:

https://blogs.sap.com/2012/06/11/active-directory-sso-for-sap-businessobjects-bi4/

I discovered that I'm missing a JDK folder within:

C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win64_x64>

Needless to say, I have been unsuccessful at getting SSO running when testing using the WebI Rich Client, so I'm assuming that this folder is critical.

I noticed that the Java JDK was not installed on the (Win16) server when XI4 was installed (although the JRE was). I've since installed the JDK, and am in the process of running a Repair on the XI4 installation.

Since this will likely take a while to complete, I thought I'd drop this note here in the meantime. Is there anything else that I need to do to get that JDK folder installed where it's supposed to be?

Thanks!

_________________
Mike Nagel
Office Automation Supervisor
Judiciary/AOC
State of New Jersey
Back to top
mike nagel
Senior Member
Senior Member



Joined: 18 Apr 2005

Posts: 77



PostPosted: Mon Nov 26, 2018 11:46 am 
Post subject: Re: [XI 4.2] Missing JDK folder

Just as a follow-up, installing the JDK and running a repair did nothing. Further research seems to indicate that this is a Kerberos issue (it's not recognizing my service account). I'm reaching out to my network/server guys to see what's up.
_________________
Mike Nagel
Office Automation Supervisor
Judiciary/AOC
State of New Jersey
Back to top
joepeters
Forum Fanatic
Forum Fanatic



Joined: 29 Aug 2002

Posts: 6705
Location: Connecticut, USA


flag
PostPosted: Tue Nov 27, 2018 7:58 am 
Post subject: Re: [XI 4.2] Missing JDK folder

Not sure which version that blog was written for, but in BI4.1 the jdk (sapjvm, actually) is in win64_64\sapjvm.

Joe
Back to top
mike nagel
Senior Member
Senior Member



Joined: 18 Apr 2005

Posts: 77



PostPosted: Tue Nov 27, 2018 8:17 am 
Post subject: Re: [XI 4.2] Missing JDK folder

Joe,

It's for 4.2, but it's the same as 4.1.

I tried authenticating using the manager servers button on the CCM and got a Kerberos error against our service account, so I'm having my network staff try to sniff out the issue. Hopefully it's just a port of some kind that needs to be opened.

_________________
Mike Nagel
Office Automation Supervisor
Judiciary/AOC
State of New Jersey
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0282 seconds using 18 queries. (SQL 0.0032 Parse 0.0009 Other 0.0241)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo