BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

General Notice: BOB is going to retire...please see details here.
General Notice: No events within the next 45 days.

Upload generated ABAP fails in BODS 4.1

Goto page 1, 2  Next
 
Search this topic... | Search DI: SAP-specific ERP/BW... | Search Box
Register or Login to Post    Forum Index -> Data Integrator -> DI: SAP-specific ERP/BW  Previous TopicPrint TopicNext Topic
Author Message
jwiqvist
Forum Member
Forum Member



Joined: 23 Aug 2011

Posts: 10



PostPosted: Thu Mar 14, 2013 8:56 am 
Post subject: Upload generated ABAP fails in BODS 4.1

Hi,

We have a problem with uploading ABAP functions to SAP in BODS 4.1

When using the "Generate ABAP Code" function (right click on the R3 dataflow), and selecting "Upload Generated Programs" it fails whenever the development class on the default datastore configuration is set to something different from $TMP.

Since we have a lot of ABAPs to deploy, it would be very useful to have them automatically assigned to a transport package (by changing to development class to the package name).

Appreciate any ideas!
Back to top
jwiqvist
Forum Member
Forum Member



Joined: 23 Aug 2011

Posts: 10



PostPosted: Thu Mar 14, 2013 9:06 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

... And the error message when uploading is:

[ABAP Data Flow:ABAP_AUFK_R3_DF]
Cannot generate ABAP code: <Error: <RS_CORR_INSERT:1>.>. (BODI-1111205)
Back to top
Leigh Kennedy
Principal Member
Principal Member



Joined: 16 Jan 2012

Posts: 330
Location: Sydney, Australia


flag
PostPosted: Sun Mar 17, 2013 9:34 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Did you load the new transports when you upgraded ? I don't deal with ABAP, but we had a few issues until we did this.
_________________
___________________________________
Leigh Kennedy
www.isql.org
Back to top
jwiqvist
Forum Member
Forum Member



Joined: 23 Aug 2011

Posts: 10



PostPosted: Mon Mar 18, 2013 2:18 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Yes, the new transports have been loaded.

I found a workaround though. If you first upload using $TMP and then upload again using the correct package name, it will still give the error code but the ABAP gets added to the package.
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Thu Apr 11, 2013 4:01 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Hi Leigh, what are the new transports you are referring to.
We are in process to upgrade to 4.1 and noticed that we were unable to Import BW Tables. I believe there are some specific notes out there for the same but cannot find them, and currently waiting for response from SAP.

Thanks,
Jas
Back to top
Leigh Kennedy
Principal Member
Principal Member



Joined: 16 Jan 2012

Posts: 330
Location: Sydney, Australia


flag
PostPosted: Thu Apr 11, 2013 5:01 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

They are in this directory:

SAP BusinessObjects\Data Services\admin\R3_Functions\transport

Unless you give your data services login unrestricted access, you need to install them. They changes from 4.0.

The upgrade documentation makes no mention if the change, but if you compare to a 4.0 install you'll see the files are different.

Cheers.

_________________
___________________________________
Leigh Kennedy
www.isql.org
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Sun Apr 14, 2013 11:53 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Thanks Leigh for sharing the info. In our landscape, SAP team is not ready to install any software that is provided manually by BODS. They are more comfortable with something like OSS Note which they can get directly from SAP. With 4.0 we got a corresponding SAP note, but do not have anything yet for 4.1 and could not find any info on it. We will probably have to initiate this with SAP through a ticket or something.
Back to top
Leigh Kennedy
Principal Member
Principal Member



Joined: 16 Jan 2012

Posts: 330
Location: Sydney, Australia


flag
PostPosted: Sun Apr 14, 2013 11:57 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

ERP people live in a fantasy world - Its still coming from SAP !
_________________
___________________________________
Leigh Kennedy
www.isql.org
Back to top
Werner Daehn
Forum Devotee
Forum Devotee



Joined: 17 Dec 2004

speaker.gif*6
Posts: 10591
Location: Germany


flag
PostPosted: Mon Apr 15, 2013 2:25 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

tomhawk_usa wrote:
In our landscape, SAP team is not ready to install any software that is provided manually by BODS. They are more comfortable with something like OSS Note which they can get directly from SAP.


I am working on that but it is not ready yet. If you would install a SAP NW Service Pack that got released in the last months, the DS functions would have been included in the SAP NW package (PI_BASIS).
The Note that does that I have as well but as the note assistant cannot install certain objects like AUTH objects, we have to do use transport files instead. And these transport files are not in a note yet.

_________________
Werner Daehn
ex Product Manager Data Services at SAP SE

www.rtdi.io
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Tue Apr 16, 2013 4:28 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Werner Daehn wrote:
I am working on that but it is not ready yet.


Thanks Werner, really appreciate the info. Not sure if it is right for me to ask but any idea when to expect it.

Best case scenario for our scenario is to have everything available in a note. I am not sure if we will be able convince Basis to accept transport files from BODS icon_neutral.gif so might end up waiting for the notes
Back to top
Werner Daehn
Forum Devotee
Forum Devotee



Joined: 17 Dec 2004

speaker.gif*6
Posts: 10591
Location: Germany


flag
PostPosted: Wed Apr 17, 2013 3:12 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Do you remember the movie The Money Pit?

The scene where they ask "When will it be done?" and get the response "In 14 days" for months and years.

In 14 days. mad.gif

_________________
Werner Daehn
ex Product Manager Data Services at SAP SE

www.rtdi.io
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Wed Apr 17, 2013 5:10 pm 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Werner Daehn wrote:
In 14 days.


hahaha icon_lol.gif ..I am off to watch it now, to get some clues as to what these 14 days will eventually translate into..thanks again.
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Mon Apr 22, 2013 2:02 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Hi,

We finally have the 4.1 specific transports setup in one of our SAP Dev box(BW). Got the following error when tried to import a table:

RFC_NO_AUTHORITY: No RFC Authorization for function module /BODS/<func module>

From SAP Supplement doc, and checking existing user profile, it was clear that S_RFC is required for the new function group /BODS/BODS, as the functions modules have been moved from ZAW0 to /BODS/BODS.

Now when I try to import, I get the following error:
RFC_ABAP_MESSAGE, You are not authorized to perform this activity

As per Supplement doc and werner's wiki article (http://wiki.sdn.sap.com/wiki/display/EIM/DataServices+and+SAP+Security) I understand that next step is to get ZDSAUTH assigned to the BODS SAP user profile.
As per doc, theis auth gives execute access to Data servcies functions.

Please note that this same user profile has been working fine with DS 4.0. I am trying to figure out if S_RFC on new function module + ZDSAUTH should resolve the issue.

Thanks.
Jas

[/img]
Back to top
Johannes Vink
Forum Enthusiast
Forum Enthusiast



Joined: 20 Mar 2012

Posts: 1138


flag
PostPosted: Mon Apr 22, 2013 3:26 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

What did help for me was to check the function it self. In the code you can see on which authorizations is checked before the relevant code of the function is executed.
_________________
Consultant at Teradata

The opinions expressed in this post are my own views and not those of Teradata. Apply any advise in this post at your own discretion.
Back to top
tomhawk_usa
Forum Member
Forum Member



Joined: 10 Sep 2012

Posts: 16



PostPosted: Thu Apr 25, 2013 4:50 am 
Post subject: Re: Upload generated ABAP fails in BODS 4.1

Thanks Johannes,
That was good advice. I have figured out the auths at high level through documentation + looking at Fucntion Module code, however some doubts still remain.

1) S_DEVELOP vs ZDSDEV - Both look very similar and doc also mentions that ZDSDEV is DS version of S_DEVELOP. Code also seems to check for S_DEVELOP. I dont think I so any auth checks for ZDSDEV but I may have missed. Questions is do we really need to setup ZDSDEV when S_DEVELOP is present.

2) S_DEVELOP - Tables access was controlled at package level(some kind of grouping of tables) and not individual tables. Will this still work.

Idea here is the ability to provide the reason for each auth request.
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Data Integrator -> DI: SAP-specific ERP/BW  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT - 5 Hours
Goto page 1, 2  Next
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0306 seconds using 17 queries. (SQL 0.0029 Parse 0.0009 Other 0.0268)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo