BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

General Notice: BOB is going to retire...please see details here.
General Notice: No events within the next 45 days.

SAPBI4 - UNX causing issues

Goto page 1, 2  Next
 
Search this topic... | Search Server Administration, Installation, Upgrades... | Search Box
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades  Previous TopicPrint TopicNext Topic
Author Message
Andreas
Forum Advocate
Forum Advocate



Joined: 20 Jun 2002

medal_silver.gif*2medal_gold.gif
Posts: 17346
Location: *** BEEP ...Dreaming of Africa... leave No message ; ) BEEP ***


flag
PostPosted: Fri Jan 20, 2012 3:23 am 
Post subject: SAPBI4 - UNX causing issues

Scenario: SAP BI 4.0 SP02, build 3xx, UNX build on Oracle DBMS

Problem:
When accessing a UNX via Webi (BI Launchpad) an error is thrown, something about the underlaying Data Foundation.

Note:
- I am using a full fledged BusinessOBjects Administrator account
- Webi RichClient works fine with the very same UNX
- The underlying universe connection is configured and working on the SAP BI Server, tested via a regular UNV.

Has anybody come across this issue icon_question.gif

_________________
Follow me on Twitter
Reading "The Design Of Everyday Things" by Don Norman
Focusing on Data Visualization, Design Thinking, SAP DesignStudio + scripting, SAP BI 4.x platform & architecture, SAP connectivity, Data Modeling, and SAP HANA Certified Associate
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Fri Jan 20, 2012 4:37 am 
Post subject: Re: SAPBI4 - UNX causing issues

Quote:
When accessing a UNX via Webi (BI Launchpad) an error is thrown, something about the underlaying Data Foundation


Does this happen with all of the unx universes you have created. Does this just occur when creating against this perticular Oracle source? Have you tried against another database platform?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
Andreas
Forum Advocate
Forum Advocate



Joined: 20 Jun 2002

medal_silver.gif*2medal_gold.gif
Posts: 17346
Location: *** BEEP ...Dreaming of Africa... leave No message ; ) BEEP ***


flag
PostPosted: Fri Jan 20, 2012 2:17 pm 
Post subject: Re: SAPBI4 - UNX causing issues

Only Oracle, and hey if it does not work with Oracle then....

I had one UNV converted to UNX, which does not work via BI Launchpad, and I created another one from scratch with IDT (just one Oracle table) and that one does not work in BI Launchpad either.

Keep in mind: a UNV using the very same oracle Universe connection works just fine via BI Launchpad. And with Webi RichClient those UNX work fine as well.

I am hoping that Patch 10 SP02 will fix it, but I am just hoping.

_________________
Follow me on Twitter
Reading "The Design Of Everyday Things" by Don Norman
Focusing on Data Visualization, Design Thinking, SAP DesignStudio + scripting, SAP BI 4.x platform & architecture, SAP connectivity, Data Modeling, and SAP HANA Certified Associate
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Tue Jan 24, 2012 3:34 am 
Post subject: Re: SAPBI4 - UNX causing issues

Quote:
I created another one from scratch with IDT (just one Oracle table) and that one does not work in BI Launchpad either.


Not good. Hav you had any response from SAP support? Has this ever worked for you, i.e. do you think it was a previously applied patch that may have done this?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
Andreas
Forum Advocate
Forum Advocate



Joined: 20 Jun 2002

medal_silver.gif*2medal_gold.gif
Posts: 17346
Location: *** BEEP ...Dreaming of Africa... leave No message ; ) BEEP ***


flag
PostPosted: Wed Jan 25, 2012 2:29 pm 
Post subject: Re: SAPBI4 - UNX causing issues

OK, Patch 10 for SP02 did not help. SAP BI 4.0 is installed on AIX Server. Customer opened an SAP OSS Message.

Has anybody else been encountering this problem/bug?

_________________
Follow me on Twitter
Reading "The Design Of Everyday Things" by Don Norman
Focusing on Data Visualization, Design Thinking, SAP DesignStudio + scripting, SAP BI 4.x platform & architecture, SAP connectivity, Data Modeling, and SAP HANA Certified Associate
Back to top
cpmohanraj
Forum Associate
Forum Associate



Joined: 23 Sep 2002

Posts: 720
Location: Perth, Australia


flag
PostPosted: Tue Jan 31, 2012 4:56 am 
Post subject: Re: SAPBI4 - UNX causing issues

We have a sand box

BO BI 4.0 SP02 along with Explorer, Data Services 4.0 and Information Steward. We turn the different services on and off.

All of a sudden, the data provider creation using Webi rich internet application through UNX universes fail for every type of database connection. I tested this for eFashion, SQL Server 2008 and SAP BW. All these used to work some days back.

The UNV universes work fine. And the webi rich client also works just fine.

And the error messages are useless as they say "The dataSource cannot be generate for the specified dataSource name "eFashion.unx". (WIS 00000) for relational universes and "java.lang.UnsupportedOperationException: csEX (WIS 00000)" for SAP BW universes.

Anyone has come across something similar??

_________________
Mohanraj CP
Perth, Australia
http://blog.mohanraj.org
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Tue Jan 31, 2012 5:12 am 
Post subject: Re: SAPBI4 - UNX causing issues

Your Java has not auto updated, by any chance?
Is this happening on all work stations?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
cpmohanraj
Forum Associate
Forum Associate



Joined: 23 Sep 2002

Posts: 720
Location: Perth, Australia


flag
PostPosted: Tue Jan 31, 2012 9:06 am 
Post subject: Re: SAPBI4 - UNX causing issues

The java plugin version is 1.6_029 and I tested on couple of machines. Both throw the same error.
_________________
Mohanraj CP
Perth, Australia
http://blog.mohanraj.org
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Tue Jan 31, 2012 9:16 am 
Post subject: Re: SAPBI4 - UNX causing issues

cpmohanraj wrote:
The java plugin version is 1.6_029 and I tested on couple of machines. Both throw the same error.


Thats very new, have you always been running that version? I would be surprised if it is supported?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
cpmohanraj
Forum Associate
Forum Associate



Joined: 23 Sep 2002

Posts: 720
Location: Perth, Australia


flag
PostPosted: Tue Jan 31, 2012 9:26 am 
Post subject: Re: SAPBI4 - UNX causing issues

Windows 7 and IE8 - the PAM says Java 1.6_018 minimum but 1.7 is not supported.

But I would be surprised to see error messages only for UNX universes and not for UNV universes.

_________________
Mohanraj CP
Perth, Australia
http://blog.mohanraj.org
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Tue Jan 31, 2012 9:41 am 
Post subject: Re: SAPBI4 - UNX causing issues

1.6_30 is the latest Java Production release. I would try with an earlier version.

Quote:
But I would be surprised to see error messages only for UNX universes and not for UNV universes.


I wouldn't be, as they are totally different beasts with the differing file formats, structure e.t.c.

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
cpmohanraj
Forum Associate
Forum Associate



Joined: 23 Sep 2002

Posts: 720
Location: Perth, Australia


flag
PostPosted: Tue Jan 31, 2012 8:42 pm 
Post subject: Re: SAPBI4 - UNX causing issues

Just checked on another machine which had Java 1.6_019 and it still the same for UNX universes.

What else do I check? Any clues?

Update: I recreated the Web Intelligence Processing Server and still the web rich internet application doesn't work for UNX universes.

Crystal for Enteprise is able to use the UNX universes
Webi Rich client is able to use the UNX universes in 3-tier mode

It all led me to think that the issue is related to the webi applet used by the browser. So I deleted the webi applets from my laptop and tried accessing the web intelligence rich internet application again. Sadly the same error comes back when I select the UNX universes.

_________________
Mohanraj CP
Perth, Australia
http://blog.mohanraj.org
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Wed Feb 01, 2012 4:10 am 
Post subject: Re: SAPBI4 - UNX causing issues

Quote:
It all led me to think that the issue is related to the webi applet used by the browser.


Thats where I believed the issue lay in the first place icon_smile.gif.

Have you tried turning the Java logging on? Also, try the minimum supported Java, or even an earlier one?
Is this the same with all browsers?

Have you tried re-creating the Adaptive Processing Server, also?

Have you tweaked the run time settings in the Java applet to see whther that makes any difference, also.
If all fails you could uninstall rich client, clean all left behind folders and registry and try a re-install?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
cpmohanraj
Forum Associate
Forum Associate



Joined: 23 Sep 2002

Posts: 720
Location: Perth, Australia


flag
PostPosted: Thu Feb 02, 2012 12:32 am 
Post subject: Re: SAPBI4 - UNX causing issues

I was browsing through the different log files and found out that the error thrown is logged as part of DSL Bridge service. So I tried recreating the DSL service but it didn't help either.

The below is the complete error message logged

Code:

|17E74E175AC047B8A681B8A27DAD34DD5|2012 02 02 16:06:14.843|+1100|>>|E| |aps_SIA_BOBI.APS_DSL Bridge 2|  640| 175|Transport:Shared-10/18| |180|0|2|0|BIlaunchpad.WebApp|edwvm021:3300:44.510:1|webiserver_SIA_BOBI.WebIntelligenceProcessingServer2.processDPCommandsEx|localhost:4484:4552.1728:1|.doIt|edwvm021:640:175.18348:1|CtzkyKpzn0ZQlNCMoVAV7Dkbaa|||||||||||Exception caught in SL Service: The dataSource cannot be generated for the specified dataSource name "Adventure Works".
com.sap.sl.datasource.exception.InvalidDataSourceException: The dataSource cannot be generated for the specified dataSource name "Adventure Works".
   at com.businessobjects.dsl.services.datasource.DataSourceFactory.getDataSource(DataSourceFactory.java:675)
   at com.businessobjects.dsl.services.datasource.impl.CubeDataSourceServiceImpl.getAdaptableDataSource(CubeDataSourceServiceImpl.java:32)
   at com.sap.sl.proxyconsumption.services.datasourceservice.DataSourceServiceImpl.getDataSource(DataSourceServiceImpl.java:126)
   at com.sap.sl.proxyconsumption.protobuf.rpc.DatasourceRpc$dataSource.callMethod(DatasourceRpc.java:149)
   at com.sap.sl.proxyconsumption.services.server.DSLBridge.callService(DSLBridge.java:210)
   at com.sap.sl.proxyconsumption.services.server.DSLBridge.doIt(DSLBridge.java:148)
   at com.businessobjects.cdz_ext.slproxybridge.corba.ServerServant.doIt(ServerServant.java:116)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.businessobjects.framework.servers.platform.adapters.ebus.orb.CommonTransportInterceptor.invokeHelper(CommonTransportInterceptor.java:118)
   at com.businessobjects.framework.servers.platform.adapters.ebus.orb.CommonTransportInterceptor.invoke(CommonTransportInterceptor.java:87)
   at com.businessobjects.framework.servers.common.proxy.cglib.MethodInterceptorChain.intercept(MethodInterceptorChain.java:136)
   at com.crystaldecisions.enterprise.ocaframework.idl.OCA.OCAcdz.slproxybridge.serverPOA$$EnhancerByCGLIB$$86b080c5.doIt(<generated>)
   at com.crystaldecisions.enterprise.ocaframework.idl.OCA.OCAcdz.slproxybridge.serverPOA._OB_op_doIt(serverPOA.java:107)
   at com.crystaldecisions.enterprise.ocaframework.idl.OCA.OCAcdz.slproxybridge.serverPOA._invoke(serverPOA.java:83)
   at com.crystaldecisions.thirdparty.com.ooc.OBPortableServer.ServantDispatcher.dispatch(ServantDispatcher.java:234)
   at com.crystaldecisions.thirdparty.com.ooc.OBPortableServer.POA_impl._do_OB_dispatch(POA_impl.java:1977)
   at com.crystaldecisions.thirdparty.com.ooc.OBPortableServer.POA_impl._OB_dispatch(POA_impl.java:1913)
   at com.crystaldecisions.thirdparty.com.ooc.OB.DispatchRequest_impl.invoke(DispatchRequest_impl.java:75)
   at com.businessobjects.framework.servers.platform.adapters.ebus.orb.ThreadPoolDispatchStrategy$Dispatcher.run(ThreadPoolDispatchStrategy.java:271)
   at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
   at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
   at java.util.concurrent.FutureTask.run(FutureTask.java:138)
   at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
   at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.UnsupportedOperationException: java.lang.UnsupportedOperationException: csEX
   at com.businessobjects.connectionserver.ConnectionServer.getInstance(ConnectionServer.java:164)
   at com.businessobjects.connectionserver.ConnectionServer.getInstance(ConnectionServer.java:99)
   at com.businessobjects.mds.services.relational.CsService.<init>(CsService.java:308)
   at com.businessobjects.mds.services.solver.AbstractConnectionSolver.getCSService(AbstractConnectionSolver.java:149)
   at com.businessobjects.semanticlayer.qt.internal.QueryUniverseImpl.<init>(QueryUniverseImpl.java:137)
   at com.businessobjects.semanticlayer.qt.internal.QueryGenerationServiceImpl.<init>(QueryGenerationServiceImpl.java:95)
   at com.businessobjects.semanticlayer.qt.internal.QTImpl.newQueryGenerationService(QTImpl.java:35)
   at com.businessobjects.dsl.services.datasource.DataSourceFactory.createQueryCapability(DataSourceFactory.java:249)
   at com.businessobjects.dsl.services.datasource.DataSourceFactory.fillQueryCapability(DataSourceFactory.java:741)
   at com.businessobjects.dsl.services.datasource.DataSourceFactory.getDataSource(DataSourceFactory.java:661)
   ... 27 more
Caused by: java.lang.UnsupportedOperationException: csEX
   at com.businessobjects.connectionserver.ConnectionServer.getImplementation(ConnectionServer.java:412)
   at com.businessobjects.connectionserver.ConnectionServer.getInstance(ConnectionServer.java:131)
   ... 36 more
Caused by: java.lang.ClassNotFoundException: com.sap.connectivity.cs.extended.ConnectionServer
   at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:489)
   at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:405)
   at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:393)
   at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:367)
   at java.lang.Class.forName0(Native Method)
   at java.lang.Class.forName(Class.java:247)
   at com.businessobjects.connectionserver.ConnectionServer.getImplementation(ConnectionServer.java:408)
   ... 37 more



And at the start of the trace file, the below error is also present. Any idea about what this error means?

Code:

COLUMNS:Location|Guid|Time|Tzone|Importance|Severity|Exception|DeviceName|ProcessID|ThreadID|ThreadName|ScopeTag|MajorTick|MinorTick|MajorDepth|MinorDepth|RootName|RootID|CallerName|CallerID|CalleeName|CalleeID|ActionID|DSRRootContextID|DSRTransaction|DSRConnection|DSRCounter|User|ArchitectComponent|DeveloperComponent|Administrator|Unit|CSNComponent|Text
SEVERITY_MAP: |Information|W|Warning|E|Error|A|Assertion
HEADER_END
|17E74E175AC047B8A681B8A27DAD34DD0|2012 02 02 15:51:45.500|+1100|>>|E| |aps_SIA_BOBI.APS_DSL Bridge 2|  640|  22|Component Resolve Thread (Bundle 54)| ||||||||||||||||||||com.businessobjects.framework.servers.util.ModuleToBundle||Bundle D:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java\pjs\container\work\SIA_BOBI.AdaptiveProcessingServer3\modules\boeserver_startup.jar cannot be started
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: logging; bundle-version="0.0.0"

_________________
Mohanraj CP
Perth, Australia
http://blog.mohanraj.org
Back to top
Mak 1
Forum Aficionado
Forum Aficionado



Joined: 06 Jan 2005

Posts: 13981
Location: London


flag
PostPosted: Thu Feb 02, 2012 4:08 am 
Post subject: Re: SAPBI4 - UNX causing issues

Not really.
Did you try creating the Adaptive Job Server as I suggested earlier?
Have you rebooted the server?
Any Windows patches put on you server, since you have installed?

_________________
Next Available for Contract Work - January 2018

Business Objects Versions 4,5,6, XI R2, 3.2, 4.1 SP3
Oracle, SQL Server, Sybase, Netezza, SAP BW.

Red Adair: "If you think it's expensive to hire a professional to do the job, wait until you hire an amateur."
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT - 5 Hours
Goto page 1, 2  Next
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0954 seconds using 17 queries. (SQL 0.0035 Parse 0.0621 Other 0.0298)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo