BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

IBIS 2014: Limitless BI 2.0 
IBIS 2014: Limitless BI 2.0 (Opens a new window)  

General Notice: Upcoming Events: BONYMAUG: May 14, BI2014 Nice, France: May 21.

Problem with SAP BW source (Open hub) table


 
Search this topic... | Search DI: Installation, Administration, and Connectivities... | Search Box
Register or Login to Post    Forum Index -> Data Integrator -> DI: Installation, Administration, and Connectivities  Previous TopicPrint TopicNext Topic
Author Message
prabhakar3130
Forum Member
Forum Member



Joined: 06 Jul 2011

Posts: 8



PostPosted: Tue Aug 23, 2011 9:04 am 
Post subject: Problem with SAP BW source (Open hub) table

Hi All,

I am using SAP-BW as a source in BODS 12.2v and I have connected through open hub. Initially I have created a sample job to test the connection there it works fine.
Now I have created a new job with the same SAP-BW source table then it's giving an error.

NOTE: I have deleted old job and still it's giving the same error.

Did anyone come across this kind of error.


240 9180 BIW-230338 23/08/2011 14:39:41 |Data flow DF_VOLUME_BW_TO_RECEP

240 9180 BIW-230338 23/08/2011 14:39:41 Open Hub destination <NMCFQMC02> at SAP system <uk1gfnsd10201_MWD_50> is being used by job <JOB_OUT_BOUND_BW_TO_JDE> at

240 9180 BIW-230338 23/08/2011 14:39:41 repository <MICROSOFT_SQL_SERVER.UK1SAWN00283.MOD_CF.MOD_CF_USER (admin repository name = MOD_CF_REPO)> . Current status is

240 9180 BIW-230338 23/08/2011 14:39:41 <notification has been received by RFC Server.>

9984 708 BIW-230338 23/08/2011 14:39:41 |Data flow DF_VOLUME_BW_TO_RECEP

9984 708 BIW-230338 23/08/2011 14:39:41 Open Hub destination <NMCFQMC02> at SAP system <uk1gfnsd10201_MWD_50> is being used by job <JOB_OUT_BOUND_BW_TO_JDE> at

9984 708 BIW-230338 23/08/2011 14:39:41 repository <MICROSOFT_SQL_SERVER.UK1SAWN00283.MOD_CF.MOD_CF_USER (admin repository name = MOD_CF_REPO)> . Current status is

9984 708 BIW-230338 23/08/2011 14:39:41 <notification has been received by RFC Server.>
Back to top
Codehopper
Senior Member
Senior Member



Joined: 14 May 2010

Posts: 86



PostPosted: Wed Dec 14, 2011 11:28 pm 
Post subject: Re: Problem with SAP BW source (Open hub) table

Hi, have you solved this one finally?

I'm having the same issue.

Anyone?
Back to top
manoj_d
Forum Addict
Forum Addict



Joined: 01 Jan 2009

Posts: 2634



PostPosted: Thu Dec 15, 2011 12:20 am 
Post subject: Re: Problem with SAP BW source (Open hub) table

this information is validated from one of DS repo table, I need to check which table has this mapping, you can delete the row for this job

check for tables with name line BW_REQUST, SAP_JOB or RUNTIME
Back to top
manoj_d
Forum Addict
Forum Addict



Joined: 01 Jan 2009

Posts: 2634



PostPosted: Thu Dec 15, 2011 7:26 pm 
Post subject: Re: Problem with SAP BW source (Open hub) table

check the AL_RUNTIME_PARAM, if this stores the information, you can delete this row and see if you are able to run the job successfully
Back to top
Codehopper
Senior Member
Senior Member



Joined: 14 May 2010

Posts: 86



PostPosted: Thu Dec 15, 2011 11:34 pm 
Post subject: Re: Problem with SAP BW source (Open hub) table

Hi Manoj,

I had no access to the Local Repository being used, but also I seem to have solved the issue.

Shortly before the error started to appear, I had killed a Batch Job running on that Open Hub Destination. Apparently, the termination status wasn't properly delivered from Data Services to BW -- I guess the OSS Note 1497204 should be relevant here.

So I used these a couple of BW Function Modules (RSB_API_OHS_REQUEST_SETSTATUS and RSBM_GUI_CHANGE_USTATE) to set the OpenHub DTP to Red status and then delete it. Also I restarted the RFC Server in Data Services Admin Console, however, I think that wasn't necessary.

That rectified the issue. I hope my current client will upgrade to BW 7.01 SP08 some time..
Back to top
jaja
Forum Member
Forum Member



Joined: 08 Sep 2011

Posts: 5



PostPosted: Tue May 01, 2012 2:44 pm 
Post subject: Re: Problem with SAP BW source (Open hub) table

This problem can be solved by executing the following SQL commands on the DS repository database:

select * from AL_SAP_JOB where SAP_TASK_STATUS='Y'

(Note down your SAP_OBJ_NAME and SAP_SYSTEM_ID)

UPDATE AL_SAP_JOB SET SAP_TASK_STATUS = NULL WHERE SAP_OBJ_TYPE=75 and SAP_OBJ_NAME=<Your Open Hub Name> and SAP_SYSTEM_ID='<SAP App Server Host>_<sys>_<sysnr>'

Restart the RFC Server in Data Services Management Console.
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Data Integrator -> DI: Installation, Administration, and Connectivities  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0520 seconds using 17 queries. (SQL 0.0063 Parse 0.0354 Other 0.0103)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo