BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Streamline and extend SAP BusinessObjects software 
Streamline and extend SAP BusinessObjects software (Opens a new window)  

General Notice: No events within the next 45 days.

Enterprise Auth Error QAAWS


 
Search this topic... | Search Business Query... | Search Box
Register or Login to Post    Forum Index -> Other Products -> Business Query  Previous TopicPrint TopicNext Topic
Author Message
jbrasher
Forum Member
Forum Member



Joined: 06 May 2009

Posts: 16



PostPosted: Thu Sep 17, 2009 11:55 pm 
Post subject: Enterprise Auth Error QAAWS

I have created a query as a web service and published the wsdl. In advanced parameters i have selected secSAPR3 as the authenication type and it becomes part of the soap address. I created a simple netbeans project to try to consume the web service and passed login and password. On the web service response I receive "Enterprise authentication could not log you on. Please make sure your logon information is correct. (FWB 00008) " as a message. Why is it trying enterprise login when SAP auth is specified in advanced parameters and soap url?
Back to top
jbrasher
Forum Member
Forum Member



Joined: 06 May 2009

Posts: 16



PostPosted: Mon Sep 21, 2009 7:15 am 
Post subject: Re: Enterprise Auth Error QAAWS

Even after changing qaaws.principle.authenication to secSAPR3 QAAWS is defaulting to Enterprise login. I have tested an enterprise login and it works, however is SAP auth not an option?
Back to top
jbrasher
Forum Member
Forum Member



Joined: 06 May 2009

Posts: 16



PostPosted: Thu Sep 24, 2009 9:15 pm 
Post subject: Re: Enterprise Auth Error QAAWS

There is an option in advanced parameters for Consumer Provider. This will make authentication type an input to the web service and secSAPR3 works fine. Does anyone have any experience trying to access the WSDL with an outside app. I am getting HTTP 505 which is version of http not supported. If anyone has any insight on using the wsdl with an external app please respond.
Back to top
mjyoungman
Principal Member
Principal Member



Joined: 06 Oct 2006

Posts: 110
Location: Sydney


flag
PostPosted: Thu Sep 23, 2010 6:43 pm 
Post subject: Re: Enterprise Auth Error QAAWS

G'day jbrasher,

Can you explain what you mean by 'There is an option in advanced parameters for Consumer Provider'. I have the same issue with AD authentication. Despite setting the QAAWS as AD Authentication, when I use it in an xcelsius model it's still trying to use Enterprise authentication...

Cheers!
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Other Products -> Business Query  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0502 seconds using 17 queries. (SQL 0.0044 Parse 0.0340 Other 0.0118)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo