BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Launch Works 
Launch Works (Opens a new window)  

General Notice: No events within the next 45 days.

[XI 3.1] not able to start CMS service from CCM

Goto page 1, 2  Next
 
Search this topic... | Search XI Server Discussion... | Search Box
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Author Message
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Mon Apr 06, 2009 4:48 am 
Post subject: not able to start CMS service from CCM

I am facing a strange problem with BOXI-3.1. In BOXI-3.1, in CCM, to change the properties of any server, we need to log in to Manage Servers section and updated the server settings. The problem that I am facing now is after logging in to the Manage Servers section, I had stopped the CMS service but before restarting it, I closed the Manager Server Window. Now when I am again trying to log in to the same Manage Servers section, I am asked for authentication, but as the CMS service is down, I am not able to do so. This is a strange problem and a kind of deadlock is created here. As per the Help document of CMC, it is mentioned that under the properties of Server Intelligence Agent(SIA), we should select the Auto Start CMS option which will automatically start the CMS service everytime the SIA is started. I tried this option, but still the CMS service is not starting.
Does anyone knows how can I get this issues resolved? Any help on this will really be appreciated. In case anyone knows how to start the CMS from command line, then please suggest.
Thanks in advance!!
-Tushar
Back to top
vamsi.reddy21
Senior Member
Senior Member



Joined: 28 Mar 2008

Posts: 84
Location: Bangalore


flag
PostPosted: Mon Apr 06, 2009 4:52 am 
Post subject: Re: not able to start CMS service from CCM

If you want to change the properties of any server, logon to CMS, Go to Servers window and change the properties of any server. In CCM, you can't able to change the properties of any server.
Restart the SIA, and check in the task manager is CMS service is running or not? If it is running then follow the above steps to change the properties of server.
Back to top
haider
Forum Groupie
Forum Groupie



Joined: 18 Jul 2005
ASUG Icon
medal_gold.gif
Posts: 9171
Location: Kuwait


flag
PostPosted: Mon Apr 06, 2009 4:52 am 
Post subject: Re: not able to start CMS service from CCM

Quote:
I am asked for authentication, but as the CMS service is down, I am not able to do so.

Even if the CMS is down, it should allow you to login to the manage servers authentication option
It might not be allowing due to some other reason, what is the error message you are getting in the authentication window
The CMS database may not be reachable or you are using incorrect username/password

.

_________________
BO 6.x/ BO XIr2/XI 3.1, Oracle 9i/10g//11g, SQL Server, DB2, IIS .Net/Java (Tomcat)
Back to top
vamsi.reddy21
Senior Member
Senior Member



Joined: 28 Mar 2008

Posts: 84
Location: Bangalore


flag
PostPosted: Mon Apr 06, 2009 4:54 am 
Post subject: Re: not able to start CMS service from CCM

CCM won't allow you to logon to the Manage Servers window if CMS is down.
Back to top
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Mon Apr 06, 2009 5:09 am 
Post subject: Re: not able to start CMS service from CCM

The login credentials that I am using are correct only, as I had used the same credentials to login to Manage Servers Section before stopping the CMS service.
The error that I am getting now is 'Unable to logon: Could not connect to Server -servername:6400. Please check that the server name is correct, and the server is running.
Can anyone tell me how to start the CMS again?
Back to top
vamsi.reddy21
Senior Member
Senior Member



Joined: 28 Mar 2008

Posts: 84
Location: Bangalore


flag
PostPosted: Mon Apr 06, 2009 5:13 am 
Post subject: Re: not able to start CMS service from CCM

Restarting SIA will restart the CMS server.
Back to top
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Mon Apr 06, 2009 5:19 am 
Post subject: Re: not able to start CMS service from CCM

I tried this option also. SIA restarts but again while logging in to the Manage Servers Section, it gives the same error icon_sad.gif
Back to top
vamsi.reddy21
Senior Member
Senior Member



Joined: 28 Mar 2008

Posts: 84
Location: Bangalore


flag
PostPosted: Mon Apr 06, 2009 5:22 am 
Post subject: Re: not able to start CMS service from CCM

Launch the task manager, and check that the CMS service is running or not?
Back to top
haider
Forum Groupie
Forum Groupie



Joined: 18 Jul 2005
ASUG Icon
medal_gold.gif
Posts: 9171
Location: Kuwait


flag
PostPosted: Mon Apr 06, 2009 5:23 am 
Post subject: Re: not able to start CMS service from CCM

You need to dig into it by first checking the windows event viewer for a more detailed error description
And stop the SIA, go to properties -configuration tab
Does it open up normally or any error is thrown
Also ensure that correct port number is given with servername (servername: portnumber) in the system box while authenticating for manage servers

.

_________________
BO 6.x/ BO XIr2/XI 3.1, Oracle 9i/10g//11g, SQL Server, DB2, IIS .Net/Java (Tomcat)
Back to top
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Mon Apr 06, 2009 6:19 am 
Post subject: Re: not able to start CMS service from CCM

There is no CMS Service in Task Manager (see the attached screenshot)
The following info/errors are repeatedly displayed under the Event Viewer Logs.....everytime I restarted the SIA..
information-Central Management Server stopped
information-Server Intelligence Agent: server Servername.CentralManagementServer stopped with exit code = 5 (0x5).
error-Server Intelligence Agent: server Servername.CentralManagementServer stopped unexpectedly.
info-Server Intelligence Agent: server servername.CentralManagementServer has been started.
info-Central Management Server started
error-An unexpected problem (exception) happened. Reason given: The port number specified for the server is already in use., The server has problems using TCP/IP. The port number you are using is probably already in use..
error-The root server reported an error Initialization Failure. (Reason: An unexpected problem (exception) happened. Reason given: The port number specified for the server is already in use., The server has problems using TCP/IP. The port number you are using is probably already in use..).
Back to top
abhishek_mshr
Forum Member
Forum Member



Joined: 06 Apr 2009

Posts: 6



PostPosted: Mon Apr 06, 2009 6:32 am 
Post subject: Re: not able to start CMS service from CCM

Hi Tushar,

Seems like the cms port is already in use.try to restart the machine.

thanks
Abhishek
Back to top
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Mon Apr 06, 2009 6:37 am 
Post subject: Re: not able to start CMS service from CCM

Hi Abhishek,
I restarted the system and again restarted the SIA but still the issues is there. icon_sad.gif
Back to top
haider
Forum Groupie
Forum Groupie



Joined: 18 Jul 2005
ASUG Icon
medal_gold.gif
Posts: 9171
Location: Kuwait


flag
PostPosted: Mon Apr 06, 2009 7:19 am 
Post subject: Re: not able to start CMS service from CCM

The CMS may have been configured on port 6400
You need to contact your windows or network administrator to check the port being used by any other application

.

_________________
BO 6.x/ BO XIr2/XI 3.1, Oracle 9i/10g//11g, SQL Server, DB2, IIS .Net/Java (Tomcat)
Back to top
jayjaiswal
Senior Member
Senior Member



Joined: 17 May 2008

Posts: 73
Location: Chicago


flag
PostPosted: Mon Apr 06, 2009 8:02 am 
Post subject: Re: not able to start CMS service from CCM

Hi

You may add 1 SIA along with CMS on different port and point it same system database and FRS(IFRS/ OFRS) . It will work.

_________________
Enjoy

---------------------------------

BO 6.5, BOXI R2, BOXI 3.0/3.1 ,SAP BI 4.0 /4.1
Oracle 9i,10g ,11g
Informatica 7x ,8.6 , 9.5
IBM Netezza
Back to top
Tushar Marathe
Forum Member
Forum Member



Joined: 20 Mar 2007

Posts: 13
Location: Mumbai


flag
PostPosted: Tue Apr 07, 2009 2:42 am 
Post subject: Re: not able to start CMS service from CCM

Hi Jay,

Thanks for your inputs...as suggested, I Created a new SIA i.e. SIA2 with the option 'Create default servers on the new node' and specified the same System DB and Audit DB names as that of SIA1.

As more than one SIA can't run simultaneously, I stopped SIA1 and started SIA2. Then I was able to login to the Manage Servers Section.

Now there were 2 instances of each servers and the servers those belong to SIA1 were stopped and I was not able to start them again as SIA1 was down.so finally I deleted the SIA1 and now able to work with SIA2 only.

But you also suggested to point the new CMS to same FRS(IFRS and OFRS). I could specify the same system & audit DB for the new CMS while creating the new SIA but I am not gettig as how to point it to the previous FRS?

Either way now I have deleted the SIA1 and Just need to confirm whether there will be any problem with the current setting as this is the new installation only and there were no objects in the system. Please confirm whether this is ok or not.

Once again thank you very much for the help icon_biggrin.gif

-Tushar
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT - 5 Hours
Goto page 1, 2  Next
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0515 seconds using 17 queries. (SQL 0.0024 Parse 0.0363 Other 0.0129)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo