BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

General Notice: No events within the next 45 days.

Xcelsius 2008 SP1 destroys label based menus?
1 members found this topic helpful
Goto page 1, 2  Next
 
Search this topic... | Search Xcelsius - Crystal Dashboard Design... | Search Box
Register or Login to Post    Forum Index -> Other Products -> Xcelsius - Crystal Dashboard Design  Previous TopicPrint TopicNext Topic
Author Message
BatCat
Principal Member
Principal Member



Joined: 18 May 2004

Posts: 170
Location: The North


flag
PostPosted: Tue Aug 05, 2008 6:32 am 
Post subject: Xcelsius 2008 SP1 destroys label based menus?

Hi Folks,
I have a dashboard with several Horizontal label based menus. Since I 'upgraded' to SP1 I have found that Xcelsius now drops the first item off the menu. I just end up with a blank space in the list. No rhyme or reason to it.
Anyone else found this?
banghead.gif
Cheers,
BatCat
Back to top
BatCat
Principal Member
Principal Member



Joined: 18 May 2004

Posts: 170
Location: The North


flag
PostPosted: Tue Aug 05, 2008 8:40 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi Folks,
I've had a reply to this bug on the SAP forum.
Apparently Xcelsius 2008 sp1 comes with some added Dynamic Visibility features which include:
wiping the first item from the your label based menu when using DV

wiping the first item from your radio buttons when using DV

Apparently this was discovered 'too late' in 'testing' and will be fixed in the next release.
mad.gif
Run away run away run away.
BatCat
Back to top
iguanasterix
Principal Member
Principal Member



Joined: 18 Feb 2008

Posts: 149
Location: Iceland


flag
PostPosted: Wed Aug 06, 2008 9:00 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi, I also wanted to share some problems we've been experiencing with Xcelsius 2008 SP1. (These problems didn't exist before SP1!)

1)When using QaaWS installed on a server with locale settings different to the languages included on BO's Language Packs, Business Objects Enterprise authentication fails.

Workaround: add -Duser.language=en and -Duser.region=US to Tomcat Java parameters.

2)When selecting ignore blank cells on components which get information from a QaaWS, an "undefined" value will be added for each empty row.

3)FlashVars won't be passed to child swf's.

Workaround: create an empty FlashVar Range for every FlashVar you want to pass (if you want to pass 2 variables, you'd end up with 4 ranges... I don't really know why this works)
Back to top
BatCat
Principal Member
Principal Member



Joined: 18 May 2004

Posts: 170
Location: The North


flag
PostPosted: Thu Aug 07, 2008 10:13 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Thanks!
Someone needs to teach BO/SAP the meaning of 'regression testing'.
Sigh,
BatCat
Back to top
MargaretG
Senior Member
Senior Member



Joined: 03 Jun 2008

Posts: 72



PostPosted: Thu Aug 21, 2008 1:31 pm 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi iguanasterix,
I reported the bugs you mentioned, and the developer responsible for the feature was asking if you could provide any error messages or screen shots or give more detailed description of the bug #1 (QaaWS-authentication fails).
Thank you for your help,
Margaret
Back to top
MyXcelsius
Principal Member
Principal Member



Joined: 18 Jul 2008

Posts: 169
Location: Chicago, IL


flag
PostPosted: Thu Aug 21, 2008 2:10 pm 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Many users complained the same issue with Radio Button DV. If the Developers identified it during testing, this is a critical defect and needs to be resolved ASAP. Since Label Based Menu and Radio Buttons are commonly used Components, they should fix this and release a Hot Fix immediatly. I dont think users can wait till the next release.
_________________
Regards,
Admin
http://myxcelsius.com
Xcelsius Videos: http://myxcelsius.com/videos
Email: admin@myxcelsius.com
Back to top
anttan
Forum Member
Forum Member



Joined: 22 Oct 2007

Posts: 20



PostPosted: Thu Sep 25, 2008 11:42 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi iguanasterix,

Did you ever get a solution for issue # 2 that you highlighted?

I am also getting an "undefined" value on my combo boxes when ignore end blanks is selected.

Any help on this will be much appreciated.

Thanks.
Back to top
Mafi78
Senior Member
Senior Member



Joined: 12 Oct 2006

Posts: 36
Location: Konstanz


flag
PostPosted: Mon Sep 29, 2008 7:22 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

i experience the same behaviour - a lot of undefined in comboboxes icon_wink.gif Has anybody tried to read the information from a QaaWS Data-Provider for partialResult ?

I reduced the range in Excel and tested the value for partialResult but i got never a value back - is this normal ?
Best regards
Manfred
Back to top
smccarville
Forum Member
Forum Member



Joined: 16 Sep 2008

Posts: 6



PostPosted: Fri Oct 03, 2008 8:56 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

I also ran into this bug after installing SP1, This isn't really a fix but I found that changing the List Box or Combo Box "Insertion Type" property to “Filtered Rows” reduces the number of 'Undefined' records that appear.

FYI… I haven’t really tested this to much, I’m not exactly sure what effect Filtered Rows has, I think it just populates the lists with distinct data. Anyway hopefully there will be another SP (that fixes bugs) released soon.

Regards
Scottie
Back to top
zephyrous
Principal Member
Principal Member



Joined: 12 Jan 2007

Posts: 279



PostPosted: Wed Oct 08, 2008 8:47 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi ,

I am having similar issues with the label based menu and the radio buttons where the first item disappears on applyin dynamic visibility.

But I have also noticed that this happens only after you make a selection and say if the label based menu is displayed as part of the intial screen the first item does not disappear.

has anyone run into this as well? Also, is there a hot fix available for this problem?

Thanks
Back to top
dmarks
Principal Member
Principal Member



Joined: 16 Apr 2003
ASUG Icon
speaker.gif*4
Posts: 115
Location: Southwest Ohio


flag
PostPosted: Thu Oct 30, 2008 9:05 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

SAP Note 1262197 (S-ID required to view link) identifies the "undefined" issue as product defect ADAPT01112127 with a resolution of "Resolved in Fix Pack 1 of Xcelsius 2008 Service Pack 1". However, I do not see the Fix Pack in the SAP downloads area - only Xcelsius 2008 SP1 appears there. Hopefully the fix pack will be released soon.
_________________

Dallas Marks - EVtechnologies
SAP Mentor & ASUG Volunteer
Co-author of SAP Press SAP BusinessObjects Web Intelligence, Fourth Edition
Read my daring and mundane adventures in business intelligence at DallasMarks.com

Back to top
MargaretG
Senior Member
Senior Member



Joined: 03 Jun 2008

Posts: 72



PostPosted: Sun Nov 02, 2008 8:37 pm 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

FP1 is now available for download
https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/bobj_download/main.htm
Back to top
dandamudi
Principal Member
Principal Member



Joined: 03 Jul 2008

Posts: 124
Location: Hyderabad


flag
PostPosted: Mon Nov 03, 2008 3:20 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Hi MargaretG,

Thanks for the Information

_________________
Thanks,
Srinivas Dandamudi.
Back to top
dmarks
Principal Member
Principal Member



Joined: 16 Apr 2003
ASUG Icon
speaker.gif*4
Posts: 115
Location: Southwest Ohio


flag
PostPosted: Mon Nov 03, 2008 11:45 am 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

I applied the FP this morning. The good news is that "undefined" values in QaaWS-powered selectors no longer appear. But there is some bad news - QaaWS flakiness in my existing dashboards that I'm currently attempting to quantify. I've corrected one dashboard by reimporting the QaaWS WSDLs (which of course requires remapping all of the fields... Sigh...). But it's too early to tell if installing this FP is a good or bad idea. Esp. since there does not appear to be an easy way to roll back or uninstall the FP.

I'll be updating the following blog post as I learn stuff.

_________________

Dallas Marks - EVtechnologies
SAP Mentor & ASUG Volunteer
Co-author of SAP Press SAP BusinessObjects Web Intelligence, Fourth Edition
Read my daring and mundane adventures in business intelligence at DallasMarks.com

Back to top
MyXcelsius
Principal Member
Principal Member



Joined: 18 Jul 2008

Posts: 169
Location: Chicago, IL


flag
PostPosted: Mon Nov 03, 2008 3:18 pm 
Post subject: Re: Xcelsius 2008 SP1 destroys label based menus?

Xcelsius 2008 SP1 Hot Fix is Released. Check it out. Fixes 21 issues found in SP1. May fix the issue.

http://myxcelsius.com/2008/11/03/xcelsius-2008-sp1-hot-fix-is-here/

_________________
Regards,
Admin
http://myxcelsius.com
Xcelsius Videos: http://myxcelsius.com/videos
Email: admin@myxcelsius.com
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Other Products -> Xcelsius - Crystal Dashboard Design  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT - 5 Hours
Goto page 1, 2  Next
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0336 seconds using 17 queries. (SQL 0.0027 Parse 0.0010 Other 0.0299)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo