BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Follow BOB on Twitter! 
Follow BOB on Twitter! (Opens a new window)  

General Notice: No events within the next 45 days.

XI 3.0, .NET SDK and Visual Studio 2008....GRRR!


 
Search this topic... | Search SDK (VBA/ASP/JSP)... | Search Box
Register or Login to Post    Forum Index -> SDK (VBA/ASP/JSP)  Previous TopicPrint TopicNext Topic
Author Message
hilfy
Forum Enthusiast
Forum Enthusiast



Joined: 16 Apr 2007
ASUG Icon
speaker.gif*3
Posts: 1710
Location: Atlanta, GA


flag
PostPosted: Thu May 29, 2008 3:56 pm 
Post subject: XI 3.0, .NET SDK and Visual Studio 2008....GRRR!

We are getting ready to upgrade to XI 3.0 and have a LOT of code for XI r2 using the .NET SDK that was developed in VS 2005. It works well and the only thing I have to tweak for 3.0 is the code where I get the actual file path to the input and output file repositories - it turns out I'll probably have to save the file paths to a separate XML file for each environment (Dev, QA, Production), install the appropriate file for the environment and then load it to get the path as I'm on a tight time schedule and don't have time to delve into the Web Services stuff right now. This is all using the XI r2 assemblies.

However, we're in the process of moving to Visual Studio 2008 and I've run into MANY problems with it. I thought I would pass the info along so others can plan for the upgrade without going through the hassles I've been through in the last 2 weeks.

1. VS2008 comes with Crystal 10.5. Crystal XI will NOT integrate with it and there are no plans to ever get it to integrate with it. If I install Crystal 2008, it will integrate but then it wants to change all of the XI r2 assemblies that it can to XI 3.0 assemblies when upgrading a project from 2005 to 2008. The only problem is that not all of the assemblies are available in XI 3.0 versions!

2. With the XI 3.0 assemblies, I can log in to XI 3.0, but it won't log in to XI r2. However, it errors out when I try to get the InfoStore service (_BOEService = _BOESession.GetService("InfoStore")). There error says it is unable to load version 12.0.1100.0 of the BusinessObjects.SDK assembly. This assemly doesn't come with Crystal 2008 OR with the SDK that's installed with XI 3.0. mad.gif

So, two things you need to be aware of with VS 2008:

1. If you install Crystal 2008 and you're using the XI R2 SDK to connect to BOE, it will change some but not all of the XI R2 assemblies to the XI 3.0 versions which are not compatible with the XI R2 versions of the assemblies that don't get updated. If you change the versions to the XI R2 versions for you project, every time you open the project, it will ask if you want to update it. banghead.gif

2. If you're going to use .NET to access XI 3.0 and you're using VS 2008, you MUST use the web services SDK (there are .NET clients for it installed with the SDK.)

As for me, I've just spent the day reinstalling VS2005 so that I can get this code updated and to QA (it's due tomorrow!) so that we can meet our XI 3.0 deadline. I'll look at moving everything to the web services sometime later this year when I have time to delve into it and figure out how to get it to work.

-Dell
Back to top
Atul Chowdhury
Forum Associate
Forum Associate



Joined: 07 Jul 2003

Posts: 797
Location: New Jersey



PostPosted: Fri May 30, 2008 10:18 am 
Post subject: Re: XI 3.0, .NET SDK and Visual Studio 2008....GRRR!

Thanks for the heads up, Dell -- all very interesting information, and very appreciated.
Back to top
MJRBIM
Forum Enthusiast
Forum Enthusiast



Joined: 23 Mar 2007
ASUG Icon
Posts: 1117
Location: Toronto, Canada


flag
PostPosted: Thu Sep 17, 2009 12:48 pm 
Post subject: Re: XI 3.0, .NET SDK and Visual Studio 2008....GRRR!

Can we assume that this is unchanged in the last 18-months...?

Is Visual Studio 2008 now compatible with any version of the SDKs for BOE-XI (R2) or CR-XI (R2) ..?

If this has been fixed, which service pack / fix pack do we need to be on for BOE-XI (R2) or CR-XI (R2) ..?

Is there any formal notice from SAP that explains that XI (R1 and R2) are being excluded from Visual Studio 2008 integration..and why...?

_________________
Senior Business Intelligence Consultant
Toronto, Canada
http://www.roserichardsonenterprises.com

SeagateInfo 7 -> Crystal Enterprise -> BOE-XI (R2) / (R3.1) / 4.1 | Crystal ( 7 -> 2013) design |
WebI design | Best practices for Java / .Net / Web Services
Back to top
hilfy
Forum Enthusiast
Forum Enthusiast



Joined: 16 Apr 2007
ASUG Icon
speaker.gif*3
Posts: 1710
Location: Atlanta, GA


flag
PostPosted: Thu Sep 17, 2009 2:53 pm 
Post subject: Re: XI 3.0, .NET SDK and Visual Studio 2008....GRRR!

As far as I know, there still are no plans to integrate XI. I'm in the process of upgrading all of our .NET code that interfaces with BOE to VS 2008 with the 3.1 SDK.

-Dell
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> SDK (VBA/ASP/JSP)  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0442 seconds using 17 queries. (SQL 0.0030 Parse 0.0334 Other 0.0077)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo