BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Streamline and extend SAP BusinessObjects software 
Streamline and extend SAP BusinessObjects software (Opens a new window)  

General Notice: No events within the next 45 days.

App Foundation/Tomcat 3.2.2/IIS Install


 
Search this topic... | Search Performance Management... | Search Box
Register or Login to Post    Forum Index -> Other Products -> Performance Management  Previous TopicPrint TopicNext Topic
Author Message
tbolman
Senior Member
Senior Member



Joined: 12 Feb 2003

Posts: 46
Location: Michigan


flag
PostPosted: Wed Feb 12, 2003 9:44 am 
Post subject: App Foundation/Tomcat 3.2.2/IIS Install

I am trying to setup Application Foundation 3.0 with Tomcat 3.2.2 as the application server and IIS 5 as the HTTP content server. The machine is a Windows 2000 server box, which had just been rebuilt.

Problem: When going to the http://localhost/apps/ the startup page appears with no problems. As soon as I click the Log In I get a The page cannot be found error. Since this error is so general it is hard to debug.

Tomcat is up and running correctly, I have hit the examples that came along with it and they all run correctly. IIS server seems to be up and running correctly also, I can pull up some plain HTML pages fine.

Thanks in advance for your help!
-Tim icon_smile.gif
Back to top
Steve Krandel
Forum Devotee
Forum Devotee



Joined: 24 Jun 2002

medal_bronze.gifspeaker.gif*7
Posts: 12411
Location: San Jose, California


flag
PostPosted: Wed Feb 12, 2003 11:36 am 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

Don't you need localhost:8080/apps in order for it to work. TomCat's default port is 8080.
_________________
Image link Steve Krandel
Manager, Enterprise BI Tools
Image link
Back to top
tbolman
Senior Member
Senior Member



Joined: 12 Feb 2003

Posts: 46
Location: Michigan


flag
PostPosted: Wed Feb 12, 2003 12:07 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

According to the documentation you should be able to hit the application with out specifying the port number - but I could be wrong on this.

I have tried going to the http://localhost:8080/apps/jsp/login.jsp (giving the Tomcat port ) but then I get a
WebIntelligence / SDK System Error: General CORBA Exception - after attemping to login.

Thanks again,
Tim
Back to top
khampton
Senior Member
Senior Member



Joined: 16 Aug 2002

Posts: 59



PostPosted: Thu Feb 13, 2003 3:02 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

Is AF and WebI on the same server?

If not, do you have WebI installed on you AF server?

Can you login to BusObj from this server using the sever version of BusObj 5i?

It sounds like you may have a issue pre-AF. Maybe the BOMain.key file is off or something. Just a few things to try in a multi-sever environment. A single server is much easier.

FYI... IIS and tomcat will not be supported from v3.0.2 on according to the documentation. If you setting all this up you may want to account for this.

Karl
Back to top
tbolman
Senior Member
Senior Member



Joined: 12 Feb 2003

Posts: 46
Location: Michigan


flag
PostPosted: Thu Feb 13, 2003 3:19 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

Yes, AF and WebI are on the same server. I can log into WebI with no problems, runs as it is supposed to. I also have logged into BusinessObjects on this server with out a problem

This morning I was informed that Application Foundation 3.0 was not compatible with Webi 2.7.2 but is compatible with 2.7.1. I was wondering if anyone has found this to be True or False.

Thanks again for everyone's help,
-Tim


Last edited by tbolman on Thu Feb 13, 2003 3:34 pm, edited 1 time in total
Back to top
khampton
Senior Member
Senior Member



Joined: 16 Aug 2002

Posts: 59



PostPosted: Thu Feb 13, 2003 3:28 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

I believe the versions are pretty important. It's primarily the SDK that AF interfaces with. Which reminds me, did you install the SDK while setting up WebI? If not, there's no interface between AF and WebI. Also, you need to install the ZABO component as well.

Ruling all that out, then their must be something off with IIS or Tomcat. Is the isapi filter up in IIS?

If you are runing 2.7.2 why not use AF 3.0.2? It is sompatible, just head the IIS/Tomcat warning...

Karl
Back to top
Steve Krandel
Forum Devotee
Forum Devotee



Joined: 24 Jun 2002

medal_bronze.gifspeaker.gif*7
Posts: 12411
Location: San Jose, California


flag
PostPosted: Thu Feb 13, 2003 8:43 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

App Foundation 3.0.1 came before 2.7.2. I tried for days to get it to work. I simply could never get it to work correctly. I downgraded to 2.7.1 and it worked very easily.
_________________
Image link Steve Krandel
Manager, Enterprise BI Tools
Image link
Back to top
Mark McBride
Senior Member
Senior Member



Joined: 05 Sep 2002

Posts: 88
Location: A-Wandering


flag
PostPosted: Fri Feb 14, 2003 10:55 am 
Post subject: AF

We also tried 3.0.2 with 2.7.1 and 2.7.2 and were having more problems then usual.

So we backed down to 3.0.1 and 2.7.1 and things are stable again.
Back to top
digpen
Forum Addict
Forum Addict



Joined: 15 Aug 2002

Posts: 2854
Location: Building the next big thing...


flag
PostPosted: Fri Feb 14, 2003 4:14 pm 
Post subject: Re: App Foundation/Tomcat 3.2.2/IIS Install

tbolman wrote:
This morning I was informed that Application Foundation 3.0 was not compatible with Webi 2.7.2 but is compatible with 2.7.1. I was wondering if anyone has found this to be True or False.


Tim,

That's correct. I was sent the latest version of AF, BO and WEBI and they did not work together. I had to find old archived versions of BO and WEBI to "downgrade" to get the installation to work. Interesting since the older versions of WEBI and BO are not available online anymore.

-RM
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Other Products -> Performance Management  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0593 seconds using 17 queries. (SQL 0.0131 Parse 0.0357 Other 0.0105)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo