BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Launch Works 
Launch Works (Opens a new window)  

General Notice: No events within the next 45 days.

Creating a Hyperlink in a Webi Report

Goto page 1, 2  Next
 
Search this topic... | Search WebIntelligence XI... | Search Box
Register or Login to Post    Forum Index -> Building Reports -> WebIntelligence XI  Previous TopicPrint TopicNext Topic
Author Message
di652
Forum Associate
Forum Associate



Joined: 24 Feb 2005

Posts: 921



PostPosted: Fri Dec 18, 2009 11:46 am 
Post subject: Creating a Hyperlink in a Webi Report

I have a report that I want to use one of the fields(say Product) as a hyperlink to another report.

How can you do this in XI R3
Back to top
BO_Stuffed
Principal Member
Principal Member



Joined: 29 Mar 2008
ASUG Icon
Posts: 489
Location: London



PostPosted: Fri Dec 18, 2009 12:39 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

Set the webintelligence edit preferences to Interactive -> Return to the report -> right click on the column -> Hyperlink -> New and then it is self explanatory; its a wizard for you to play with.

Cheers.

_________________
Together - We grow.....

Business Objects Version 6, XI R2, 3.1
Oracle, SQL Server
Back to top
di652
Forum Associate
Forum Associate



Joined: 24 Feb 2005

Posts: 921



PostPosted: Fri Dec 18, 2009 12:56 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

Thanks, but when I change the Preference for Editing to Interactive the view on the report is different
I don't see the Data tab which allows me to bring in a column(click & drag) ?
Back to top
BO_Stuffed
Principal Member
Principal Member



Joined: 29 Mar 2008
ASUG Icon
Posts: 489
Location: London



PostPosted: Fri Dec 18, 2009 1:06 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

There is "Available Object" tab on the left hand side and from where you can still drag objects and create reports.

Cheers.

_________________
Together - We grow.....

Business Objects Version 6, XI R2, 3.1
Oracle, SQL Server
Back to top
di652
Forum Associate
Forum Associate



Joined: 24 Feb 2005

Posts: 921



PostPosted: Fri Dec 18, 2009 1:42 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

Thanks BO_Stuffed, I found it with your help.

I thought navigating through Webi would be easier than this. Maybe that's why I still prefer Deski.

icon_smile.gif
Back to top
Nivas74
Forum Member
Forum Member



Joined: 07 Dec 2009

Posts: 25



PostPosted: Tue Dec 22, 2009 11:11 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

Quote:
Set the webintelligence edit preferences to Interactive -> Return to the report -> right click on the column -> Hyperlink -> New and then it is self explanatory; its a wizard for you to play with.


Does this available in XI-R2? reason for asking is when I change to interactive I couldn't able to see this hyperlink wizard.

- Nivas
Back to top
di652
Forum Associate
Forum Associate



Joined: 24 Feb 2005

Posts: 921



PostPosted: Mon Dec 28, 2009 9:58 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

You should be able to do this in R2; but have to admit I never actually tried creating a hyperlink in that version.

After you set your preference to 'Interactive' what happened when you went to the field and did a 'Right-Click'? Did you see the option to 'Create a New Hyperlink?
Back to top
joepeters
Forum Addict
Forum Addict



Joined: 29 Aug 2002

Posts: 4766
Location: Connecticut, USA


flag
PostPosted: Mon Dec 28, 2009 10:03 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

The wizard is not available in XIr2; you have to build the openDocument link manually.

Joe
Back to top
Nivas74
Forum Member
Forum Member



Joined: 07 Dec 2009

Posts: 25



PostPosted: Mon Dec 28, 2009 10:31 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

Thank you, Joe & di652

As Joe confirmed looks like the wizard is not available in XI-R2. So I used the OpenDocument function. When I use the OpenDocument function, the hyperlink seems created in Master report. However when I click on hyperlink filed ("Account Number" which supposed to passed as paramet to the child report) I am getting the below error.

"Internal Error: the value of the paramet id is invalid.(Error:INF)"

I am using the link as below

Code:
="<a href=https://server/businessobjects/enterprise115/desktoplaunch/opendoc/openDocument.jsp?&sWindow=Same&sInstance=Param&sType=wid&sPath=Training,Sub+Folder&sRefresh=Y&sReportName="+URLEncode("ChildReport")+">"+[Account Number]+ "</a>"


Am I missing something? Any ideas?

-Nivas
Back to top
joepeters
Forum Addict
Forum Addict



Joined: 29 Aug 2002

Posts: 4766
Location: Connecticut, USA


flag
PostPosted: Mon Dec 28, 2009 10:42 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

sReportName is used to specify a report tab; you want sDocName. Also, you don't need URLEncode around static text that doesn't contain URL-unfriendly characters.

The folder names in the sPath parameter must be enclosed in brackets, and the first one must be [Public Folders].

You don't need the ampersand in the first parameter name.

You're using the "Param" option but not passing any prompt parameters to the child report. Is that intentional? And I don't think sRefresh makes sense when using sInstance=Param.

Try this:

Code:

="<a href=https://server/businessobjects/enterprise115/desktoplaunch/opendoc/openDocument.jsp?sWindow=Same&sInstance=Param&sType=wid&sPath=[Public+Folders],[Training],[Sub+Folder]&sRefresh=Y&sDocName=ChildReport>"+[Account Number]+"</a>"


Joe
Back to top
Nivas74
Forum Member
Forum Member



Joined: 07 Dec 2009

Posts: 25



PostPosted: Mon Dec 28, 2009 11:39 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

Thanks again, Joe.

This time I am getting the below erorr

"Report Linking Error

There was an error retrieving data from the server:
The report of [Public Folders],[Training],[Sub Folder].ChildReport cannot be found! "

I have double checked the path and report names, both Main and Child reports are in Training folder under public.

Regarding the parameter, just to clarify I want to pass Account Number as a parameter to child report.

- Nivas
Back to top
joepeters
Forum Addict
Forum Addict



Joined: 29 Aug 2002

Posts: 4766
Location: Connecticut, USA


flag
PostPosted: Mon Dec 28, 2009 11:43 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

I was going to ask about that "Sub+Folder" name icon_smile.gif

You probably saw that in an example; you just need "[Public Folders],[Training]" if it's in a folder called "Training".

To pass the parameter to the child report, you first must ensure that the child has a prompt that will receive the value, then add an &lsS or &lsM parameter to the openDocument string. Note that you're calling the prompt by its text, not the object name. If you have a prompt "Enter Account Number" in the child, which accepts one value, then your openDocument string will include:
Code:
&lsSEnter+Account+Name="+[Account Number]+"...


Joe
Back to top
Nivas74
Forum Member
Forum Member



Joined: 07 Dec 2009

Posts: 25



PostPosted: Tue Dec 29, 2009 3:26 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

Thank you, Joe

It seems working now. I have used...

Code:

="<a href=https://..../businessobjects/enterprise115/desktoplaunch/opendoc/openDocument.jsp?&sWindow=Same&sType=wid&NAII=Y&sDocName=ChildReport&lsSEnter+Account+Number:="+URLEncode([Account Number])+">"+[Account Number]+ "</a>"


though I had one question...right now the Account Number variable is passing from Master report to Child report and the child report is refreshing with the prompt value from the master report. Looks like the the child report is not prompting through I use NALI=Y. Am I doing something wrong?

-Nivas
Back to top
joepeters
Forum Addict
Forum Addict



Joined: 29 Aug 2002

Posts: 4766
Location: Connecticut, USA


flag
PostPosted: Wed Dec 30, 2009 8:00 am 
Post subject: Re: Creating a Hyperlink in a Webi Report

So you want the user to see the prompt panel when the child report is opened? You can just leave off the &lsS parameter if so.
Back to top
Nivas74
Forum Member
Forum Member



Joined: 07 Dec 2009

Posts: 25



PostPosted: Fri Jan 15, 2010 8:28 pm 
Post subject: Re: Creating a Hyperlink in a Webi Report

Is there a way I can put the prompt in hyperlink for the child report? Basically when the user click on the hyperlink column on the master report it should promprt for child report name. Once user enter the child report name that respective child report shold show up. Any ideas?

-Nivas
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Building Reports -> WebIntelligence XI  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT - 5 Hours
Goto page 1, 2  Next
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0487 seconds using 17 queries. (SQL 0.0031 Parse 0.0352 Other 0.0104)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo