BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

 
Lead By Knowing (Opens a new window)  

General Notice: No events within the next 45 days.

Crystal Report -- Security Plugin Error


 
Search this topic... | Search Crystal Reports... | Search Box
Register or Login to Post    Forum Index -> Building Reports -> Crystal Reports  Previous TopicPrint TopicNext Topic
Author Message
Grimsbody
Forum Member
Forum Member



Joined: 31 Oct 2005

Posts: 14
Location: Kansas City, Missouri


flag
PostPosted: Wed Feb 27, 2008 10:57 am 
Post subject: Crystal Report -- Security Plugin Error

I have a user that is attempting to simply login to the repository explorer and is receiving the error:

"Security plugin error: An error has occurred in the plugin, but the plugin is unable to return a detailed error message."

The user has reinstalled crystal after a clean uninstall but is still getting the error. I've encountered this same issue in the past but I simply can't remember the resolution.

_________________
Shaun Horner
Business Intelligence Reports Engineer
Perceptive Software, Inc.
Shawnee, KS
Back to top
hsalem
Senior Member
Senior Member



Joined: 05 Jan 2006

Posts: 36



PostPosted: Tue Jul 15, 2008 12:09 pm 
Post subject: Re: Crystal Report -- Security Plugin Error

Have you figured out the problem here. I have the same issue.
Back to top
Grimsbody
Forum Member
Forum Member



Joined: 31 Oct 2005

Posts: 14
Location: Kansas City, Missouri


flag
PostPosted: Mon Aug 04, 2008 12:54 pm 
Post subject: Re: Crystal Report -- Security Plugin Error

Sadly, no. We had to do several installs. It took a complete reimage before the message went away.
_________________
Shaun Horner
Business Intelligence Reports Engineer
Perceptive Software, Inc.
Shawnee, KS
Back to top
citizenDNPB
Forum Member
Forum Member



Joined: 20 Apr 2009

Posts: 1



PostPosted: Mon Apr 20, 2009 12:10 pm 
Post subject: Re: Crystal Report -- Security Plugin Error

I have recently ran into this issue as well, did either of you managed to find a resolution?

[edit]
Looks like I'm a forum necromancer today.
Back to top
thartm
Forum Member
Forum Member



Joined: 31 May 2007

Posts: 24



PostPosted: Mon Apr 20, 2009 1:21 pm 
Post subject: Re: Crystal Report -- Security Plugin Error

Can you tell what versions of BO and CR you have? I had a similar issue with CR XI r1, and BO XI r2.
Back to top
zcs0119
Forum Member
Forum Member



Joined: 15 Jun 2009

Posts: 1



PostPosted: Mon Jun 15, 2009 9:37 am 
Post subject: Re: Crystal Report -- Security Plugin Error

I've got a solution that worked for me. I've searched for this since installing SP3 which is the SP that caused my problem to occurr.

To solve the issue of being able to login to the Repository Explorer with a user ID and Windows AD authentication do the following:

Copy the two listed files from the CE XIR2 Server to the CR machine.

smcommonutil.dll
smerrlog.dll

These files reside in Windows\System32 on the CE Server and need
to be copied to the same directory location on the CR client.

I'd suggest you make sure the file versions are the same between the server and the client. For example if the server is running SP5. The client should be running SP5.
Back to top
EddieG
Forum Member
Forum Member



Joined: 21 Jul 2009

Posts: 1



PostPosted: Tue Jul 21, 2009 4:17 pm 
Post subject: Re: Crystal Report -- Security Plugin Error

Oh my Lord! Thank you zcs0119 for putting me on the right path...

I am currently running CRS2008 with various versions of CR clients running accross my enterprise. Not to mention plenty of remote Terminal Services users as well.

Here's my wrinkle that I was able to iron out:
My BOE is loaded on a seperate drive [D:\] from the standard system drive [C:\]

I searched my D: drive, found the files here: Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\

After I loaded them to the CR clients & terminal server Windows\System32 folder paths EVERYONE could connect.
Back to top
gholbrook
Forum Member
Forum Member



Joined: 05 May 2010

Posts: 1



PostPosted: Wed May 05, 2010 7:02 pm 
Post subject: You ROCK!

You saved me a lot of painful work. Thank you. Thank you! THANK YOU!
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Building Reports -> Crystal Reports  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0467 seconds using 17 queries. (SQL 0.0031 Parse 0.0355 Other 0.0081)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo