BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Sunset Ride 
Sunset Ride 

General Notice: BOB is going to retire...please see details here. All BOB forums have been converted to "read only" as of September 1st.
General Notice: No events within the next 45 days.

Slow webi


 
Search this topic... | Search General Discussion... | Search Box
Register or Login to Post    Forum Index -> General Discussion  Previous TopicPrint TopicNext Topic
Author Message
Debbie
Forum Addict
Forum Addict



Joined: 01 Mar 2005

Posts: 2805
Location: Cheshire, England


flag
PostPosted: Wed Feb 12, 2020 4:18 am 
Post subject: Slow webi

We have a major issue with webi reports (4.1 SP7) timing out. There doesn't seem to be any consistency to this. A report can run in 8 minutes on one day and time out (30 mins+) the next day. There is nothing untoward happening elsewhere on the network that we can see. When you look at the oracle (11g) execution plan, for the slow-run, it picks a completely different path.

Yesterday I compared two almost the same reports - just different date filters. One ran fast, the other slow. Different execution plan again. Ah, we thought - it's indexes. So we made sure the indexes on the two date filters were the same.

This morning, the fast report is also slow.

We are running out of ideas here. The business is screaming that the service they're getting is not adequate and we can't get anything to run consistently.

Does anybody have any suggestions? At all?

Debbie
Back to top
RikDeclercq
Forum Associate
Forum Associate



Joined: 28 Sep 2006

Posts: 571


flag
PostPosted: Thu Feb 13, 2020 10:15 am 
Post subject: Re: Slow webi

I have no solution for this but I would remake the report to see what happens.
Back to top
Rich
Forum Associate
Forum Associate



Joined: 04 Oct 2002

Posts: 910
Location: London


flag
PostPosted: Fri Feb 14, 2020 5:56 am 
Post subject: Re: Slow webi

Doesn't sound like Webi is the issue to me here but Oracle is, have you taken the report SQL out and run it directly in SQLDeveloper or something and checked the explain plan there ? Have you tried updating the Oracle stats on the days it runs slow and see if it changes the explain plan ? Also date filters depending on what the difference is can change the explain a lot for example you might have the filter in such a way Oracle thinks a full table scan is the most efficient way vs another filter it may think using the index better.
_________________
Business Objects v5, v6, XI R2 and R3.1. Oracle 9i - 11g. OBIEE 10g - 11g (Oracle Business Intelligence Enterprise Edition), OWB 10g, 11g (Oracle warehouse builder). SAS 9.2. Sybase ASE and IQ. Qlikview. Spotfire.
Back to top
Mark P
Forum Devotee
Forum Devotee



Joined: 03 Feb 2003
ASUG Icon
Posts: 11524
Location: Manchester, UK


flag
PostPosted: Fri Feb 14, 2020 10:31 am 
Post subject: Re: Slow webi

Your SQL Server estate may be the issue Debbie.

Re-running the SQL in SSMS may help or not (it may be cacheing so giving a false positive). I'd get the DBA involved in the first instance to see if there are any performance benefits.

If they find it's not an issue, then Webi server and networks admins may be able to help identify anything untowards.

_________________
Current version I'm using: 4.1 SP3 over Oracle. Well versed in SQL Server too, including SSIS

______________________________________
Prior versions used: BO3,4,5,6.5,XIr2,XI3, 4.1 - yes, I have been using BO since 1996!
Back to top
Debbie
Forum Addict
Forum Addict



Joined: 01 Mar 2005

Posts: 2805
Location: Cheshire, England


flag
PostPosted: Tue Feb 18, 2020 9:27 am 
Post subject: Re: Slow webi

We're in Oracle territory here - and the DBA retired last summer....

A colleague and I spent a couple of days looking at execution plans and adding more indexes. We've cut the SQL, stripped it back, run it in TOAD etc etc …

Got last week's tranche of reports working a bit better. Main business guy is off this week so we have a break before we start again! Still can't figure out why the same report performs differently on different days, though.

Debbie
Back to top
Mark P
Forum Devotee
Forum Devotee



Joined: 03 Feb 2003
ASUG Icon
Posts: 11524
Location: Manchester, UK


flag
PostPosted: Thu Feb 20, 2020 3:27 am 
Post subject: Re: Slow webi

No DBA? eek.gif

Good luck. Networks bod/team may be able to help.

Is the database on a VM or physical?

_________________
Current version I'm using: 4.1 SP3 over Oracle. Well versed in SQL Server too, including SSIS

______________________________________
Prior versions used: BO3,4,5,6.5,XIr2,XI3, 4.1 - yes, I have been using BO since 1996!
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> General Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0324 seconds using 17 queries. (SQL 0.0034 Parse 0.0010 Other 0.0279)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo