BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

General Notice: No events within the next 45 days.

[BI 4.x] CMS Failover for CCM Command Line Call


 
Search this topic... | Search XI Server Discussion... | Search Box
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Author Message
JohnBClark
Forum Enthusiast
Forum Enthusiast



Joined: 27 Mar 2007
ASUG Icon
Posts: 1015
Location: Appleton, WI USA


flag
PostPosted: Wed Apr 10, 2019 3:35 pm 
Post subject: CMS Failover for CCM Command Line Call

Has anyone attempted to create failover redundancy for logging into the CMS when using command line scripts such as the ones that are used with the CCM or the Promotion Manager scripting?

It appears that the configuration only wants to see it in the form of %Server%:6400.

Another option that I thought of but haven't had time to investigate would be some type of attempt to connection to one CMS and if it isn't available attempt to connection to a secondary CMS (in the same cluster).

We have some interfaces that are external to Business Objects and are attempting to put some type of failover redundancy in place for them.

We tried creating an AName record on our loadbalancer (F5) but the scripts weren't able to connect. The message was
Code:
Could not reach CMS '%LoadBalanceName%:6400'. Specify the correct host and port and check for network issues. (FWM 20030)
This particular message was when trying to use the lcm_cli.bat for Promotion Management but it could be applicable for CCM.exe calls as well.
_________________
BusinessObjects BI4.2sp4, SQL Server 2016 (CMS)
Clustered for fail over redundancy
Reporting Tools: Crystal Reports 2016sp4, Web Intelligence
Operating System: Windows 2016 running on VMWare
Reporting databases: SQL Server, Teradata, DB2, Oracle
Information Steward 4.2sp10
History: BO5, BO6, XIR2, XI3.1, BI4.1.x
Back to top
JohnBClark
Forum Enthusiast
Forum Enthusiast



Joined: 27 Mar 2007
ASUG Icon
Posts: 1015
Location: Appleton, WI USA


flag
PostPosted: Fri Apr 12, 2019 2:04 pm 
Post subject: Re: CMS Failover for CCM Command Line Call - SOLVED

I found a way to code this using PowerShell.
Code:
$Server1_CMS = Get-Process -ComputerName Server1.sentry.com -Name CMS -ErrorAction SilentlyContinue
If ($Server1_CMS) {
# "Server1 CMS running"
$CMS = 'Server1:6400'
}
Else {
# "Server1 CMS not running"
$Server2_CMS = Get-Process -ComputerName Server2.sentry.com -Name CMS -ErrorAction SilentlyContinue
  If ($Server2_CMS) {
  # "Server2 CMS running"
  $CMS = 'Server2:6400'
  }
}
$CCM='D:\BOE\SAP BusinessObjects Enterprise XI 4.0\win64_x64\ccm.exe'
$NODE='NodeID'
$CCM -managedstart $NODE'.ConnectionServer' -cms $CMS -username $UID -password $PWD -authentication secEnterprise

_________________
BusinessObjects BI4.2sp4, SQL Server 2016 (CMS)
Clustered for fail over redundancy
Reporting Tools: Crystal Reports 2016sp4, Web Intelligence
Operating System: Windows 2016 running on VMWare
Reporting databases: SQL Server, Teradata, DB2, Oracle
Information Steward 4.2sp10
History: BO5, BO6, XIR2, XI3.1, BI4.1.x
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0297 seconds using 17 queries. (SQL 0.0023 Parse 0.0009 Other 0.0266)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo