BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Follow BOB on Twitter! 
Follow BOB on Twitter! (Opens a new window)  

General Notice: No events within the next 45 days.

[BI 4.x] Questions around deploying one more webnode?


 
Search this topic... | Search XI Server Discussion... | Search Box
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Author Message
arjunanand
Principal Member
Principal Member



Joined: 30 Aug 2007
ASUG Icon
Posts: 240


flag
PostPosted: Sat Mar 02, 2019 10:55 am 
Post subject: Questions around deploying one more webnode?

Hello gurus,

I am first time doing this, thought to get some advise from you folks.

we are windows 2106 servers, BO 4.2 SP5.
currently we have deployment as below.

Server1 - CMS, FRS,AJS,APS
Server2 - CMS,FRS,AJS, APS
ServerWeb1 - Tomcat

Server1 and Server2 are my App servers clustered.
I have ServerWeb1 as Webserver with tomcat as the host.

all the end users has the link to use BI Launchpad as below.
https://ServerWeb1:8080/BOE/BI.

to make webnode as high availability. I am planning on adding one more to current webnode which would be ServerWeb2.

When I am deploying server componnets with only Web Tier on the new node ServerWeb2.

here are my questions below:
would installation take care of having them both webndoes (Web1,Web2)as clusterd?
with this does end user need to change the url?
with current URL as above, would it also automatically ServerWeb2 Tomcat aslo be used?

I appreciate your inputs and advices.
Back to top
Hayden_Gill
Forum Associate
Forum Associate



Joined: 15 Aug 2002

Posts: 620
Location: Brisbane, Australia


flag
PostPosted: Sun Mar 03, 2019 10:05 pm 
Post subject: Re: Questions around deploying one more webnode?

arjunanand wrote:

would installation take care of having them both webndoes (Web1,Web2)as clusterd?
with this does end user need to change the url?
with current URL as above, would it also automatically ServerWeb2 Tomcat aslo be used?


No, you need to setup some form of load balancing.
Code:

       clusterweb.org.com
        /              \
   web1.org.com     web2.org.com

Users will need to be directed to your clusterweb address, and then the software on your loadbalancer pushes the requests to web1 or web2.

You will also need to set some form of 'sticky session' setting, such that whan user A is directed to web1 for example, all subsquent requests for that session continue to be sent to web1.

You can use a hardware loadbalancer (Cisco,BigIP etc) or you can use software like Apache.[/code]

_________________
Hayden Gill
Associate Director, BI
The University of Queensland
Brisbane, Australia
http://pbi.uq.edu.au
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Server Administration, Installation, Upgrades -> XI Server Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0304 seconds using 17 queries. (SQL 0.0027 Parse 0.0009 Other 0.0267)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo