BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Want to sponsor BOB? 
Want to sponsor BOB? (Opens a new window)  

General Notice: No events within the next 45 days.

New Install/Upgrade Question


 
Search this topic... | Search General Discussion... | Search Box
Register or Login to Post    Forum Index -> General Discussion  Previous TopicPrint TopicNext Topic
Author Message
dgui34
Forum Member
Forum Member



Joined: 10 Sep 2018

Posts: 4



PostPosted: Tue Sep 11, 2018 1:52 pm 
Post subject: New Install/Upgrade Question

Hello All!

While trying to do an upgrade from 4.1 SP7 to 4.2 SP5, there were some errors in the installation. Attempted this twice so far and each time the ConnectionServer and ConnectionServer32 were stuck on ‘Initializing’ and the APS.DataAccess and APS.LCM were ‘Running with Errors’. This was after updating the license key to 4.2 and running the repair option of the installation didn't work.

To try to get around this, another server was created so that we can do a full install of 4.2 SP5 then copy over our existing data and universes. How would I go about moving data from the 4.1 to 4.2? Is this the right approach to the problem or should we go with a full install of 4.1 SP7, copying our data, then doing the upgrade to 4.2 SP5?

Thanks in advance!
Back to top
joepeters
Forum Fanatic
Forum Fanatic



Joined: 29 Aug 2002

Posts: 6441
Location: Connecticut, USA


flag
PostPosted: Tue Sep 11, 2018 2:09 pm 
Post subject: Re: New Install/Upgrade Question

Is the "broken" BI4.2 SP05 environment still running? If so, I would first try deleting the problematic services and re-creating them. That might resolve the issue.

If not, and you still have a working BI4.1 SP07 environment, you could use UMT to move all of the content from it into your new BI4.2 server.

I would not simply copy the CMS tables to a new database and point the BI4.2 server at it. The CMS will contain references to the other servers, and things could get messy if your new BI4.2 server thinks it's in a cluster with the existing BI4.1 server.
Back to top
dgui34
Forum Member
Forum Member



Joined: 10 Sep 2018

Posts: 4



PostPosted: Tue Sep 11, 2018 2:38 pm 
Post subject: Re: New Install/Upgrade Question

We had to go back to 4.1 SP7 from a backup because it was our live environment. When I tried to delete or do anything else to those connection servers it showed the "Configuration, auditing or enable/disable state change rejected; server ConnectionServer is currently being initialized" error.

4.1 is currently working so would I be using the Live to Live option in UMT to move our data over to 4.2?

Also, I'm not sure how to start the CMS on the new server. I named the node the same as our live server in the Temporary CMS then it asks for the Admin password to login to CMC, nothing I enter works and a blank password also doesn't work. Do I need to use the 'Update data source settings' with it pointing to our current CMS?

Thank you so much for the reply!!!
Back to top
joepeters
Forum Fanatic
Forum Fanatic



Joined: 29 Aug 2002

Posts: 6441
Location: Connecticut, USA


flag
PostPosted: Wed Sep 12, 2018 7:19 am 
Post subject: Re: New Install/Upgrade Question

Using the same node name on a different server can cause problems. I wouldn't recommend it if the original server is still online.

Fundamentally, there are two ways to upgrade a BO environment onto a different server:
1) Do a completely fresh installation -- new CMS database, new cluster name, new FRS, etc. Then use UMT to migrate the content from the old environment into the new one.
2) Install the same version of the software onto the new server (BI4.1 SP07 in your case). Do an "add" install so that you point to the current CMS database. This will join the new server to the existing cluster. Then shut down the original server and upgrade the new one to BI4.2.

The first option is safer, since you'll have two functional parallel environments, until you decide to shut down the BI4.1 environment. However, it means that all your content is duplicated, and UMT doesn't always do a "perfect" copy (object IDs will change, at least).

The second option results in only a single operational environment running at a time. But, no content has to be copied.

I've never actually tested pointing a new upgraded installation at an existing CMS of a lower version to see if it upgrades. It might be worth testing -- that is, you'd delete the node you created on the BI4.2 server, and install a new node, pointing at the existing BI4.1 CMS. I don't think it will work, since it will want to connect to a running CMS of the same version, but it might be worth a shot.
Back to top
JohnBClark
Forum Associate
Forum Associate



Joined: 27 Mar 2007
ASUG Icon
Posts: 990
Location: Appleton, WI USA


flag
PostPosted: Wed Sep 12, 2018 9:15 am 
Post subject: Re: New Install/Upgrade Question

We just recently upgraded from BI4.1sp6 to BI4.2sp4.

I did a little bit of work with the Analytics Solutions Value Map people from SAP. They specifically said that pointing your BI4.2.x environment to your BI4.1.x CMS database was not recommended and that it would not work. Also, I don't think the UMT will work either because it is intended to upgrade from pre BI4.x versions to BI4.x.

The route we had to take was to use the Promotion Management command line tool to migrate all of our content from BI4.1sp7 to BI4.2sp4. The nice thing is it can be scripted but can take a while depending on how much you have in your system. This was the method recommended from the Analytics Solutions Value Map people.

_________________
BusinessObjects BI4.2sp4, SQL Server 2016 (CMS)
Clustered for fail over redundancy
Reporting Tools: Crystal Reports 2016sp4, Web Intelligence
Operating System: Windows 2016 running on VMWare
Reporting databases: SQL Server, Teradata, DB2, Oracle
Information Steward 4.2sp10
History: BO5, BO6, XIR2, XI3.1, BI4.1.x
Back to top
dgui34
Forum Member
Forum Member



Joined: 10 Sep 2018

Posts: 4



PostPosted: Wed Sep 12, 2018 10:00 am 
Post subject: Re: New Install/Upgrade Question

I'm trying the upgrade to 4.2 sp5 again today, I'll post the errors that come up in the install. There were a few other solutions that I read about where the .dll files of the MS C++ redistributables needed to be re-registered and that enabled the ConnectionServers to start properly.

If I can't get the upgrade to work then at least I'll have some downtime to copy over our data to the new server.

My plan would be to restore our current live server from backup to 4.1, the new server now has 4.1 installed. Then I can have it point to the current CMS (see attachment for the method I'm thinking of here), this would be all I need to do to have a copy of our current server? Then I would try to apply the upgrade patch to 4.2 from the new server.

If that doesn't work then I could install 4.2 on the new server and try the promotion management command line but I'm still researching how to use it now.

Once again, thank you for your replies!!
Back to top
joepeters
Forum Fanatic
Forum Fanatic



Joined: 29 Aug 2002

Posts: 6441
Location: Connecticut, USA


flag
PostPosted: Thu Sep 13, 2018 7:25 am 
Post subject: Re: New Install/Upgrade Question

dgui34 wrote:
My plan would be to restore our current live server from backup to 4.1, the new server now has 4.1 installed. Then I can have it point to the current CMS (see attachment for the method I'm thinking of here), this would be all I need to do to have a copy of our current server? Then I would try to apply the upgrade patch to 4.2 from the new server.

There is a problem with this method. When you point the new server at the copied CMS database, it will think it belongs to the same cluster as the original server (note the note below the selected option on you screenshot), and it will try to communicate with that server. If you can completely isolate this new server, then it might be possible. The procedure would be:
  • Set up the new server, copy the CMS database, point the new server at the copied CMS
  • In CMS, you'll see a node for the old server as well as the new one. However, the CCM will only show the new server's SIA.
  • On the new server, create a new SIA node with the exact same name as the old server's SIA node.
  • Immediately after creating it, delete it. The new server will no longer have a reference to the old server.

I did something like the above when a BO environment was replicated in a different domain than the original.

dgui34 wrote:
If that doesn't work then I could install 4.2 on the new server and try the promotion management command line but I'm still researching how to use it now.

Note that BI4.2 SP05 includes a new GUI for the PM CL. This is probably a better option than the command line itself.
Back to top
dgui34
Forum Member
Forum Member



Joined: 10 Sep 2018

Posts: 4



PostPosted: Fri Sep 14, 2018 1:12 pm 
Post subject: Re: New Install/Upgrade Question

So I was able to get the upgrade to 4.2 SP5 to work, after installing it I also installed 4.2 SP5 patch 4 and this actually solved the issues we were having previously.

I'd still like to get a copy of our live environment up and will try to follow your advice.

There are a few new issues with our users unable to schedule their reports to email. It seems to be a permissions issue but they do have the rights to schedule reports to SMTP, etc.

Not sure if this is related but some users are unable to authenticate using their Windows AD credentials. I recreated the BILaunchpad.properties file and ran wdeploy but still no luck resolving this.

Thank you for all your help!
Back to top
joepeters
Forum Fanatic
Forum Fanatic



Joined: 29 Aug 2002

Posts: 6441
Location: Connecticut, USA


flag
PostPosted: Sat Sep 15, 2018 10:00 am 
Post subject: Re: New Install/Upgrade Question

There are new permissions in BI4.2 related to scheduling to destinations. That is probably the reason for your problem there.

There are a lot of moving parts in Win AD authentication. First thing I'd check is if the SPNs are configured correctly for the new server, and if krb5.ini and bscLogon.ini are in place.
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> General Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0332 seconds using 17 queries. (SQL 0.0027 Parse 0.0009 Other 0.0296)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo