BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Follow BOB on Twitter! 
Follow BOB on Twitter! (Opens a new window)  

General Notice: No events within the next 45 days.

[Webi 4.x] #Error Issue


 
Search this topic... | Search Web Intelligence... | Search Box
Register or Login to Post    Forum Index -> Building Reports -> Web Intelligence  Previous TopicPrint TopicNext Topic
Author Message
aileen.tiu
Forum Member
Forum Member



Joined: 29 Jan 2018

Posts: 2



PostPosted: Mon Jan 29, 2018 9:51 pm 
Post subject: #Error Issue

Hi,

Am new to Webi. Am having a problem with one of the reports' computation.

I want to compute the total sales of an item and all item in 1 report by using Quantity multiply by Amount Price.

There are items with multiple price but with the same Article Number.

Example:

For January
Item A has Quantity of 200 with amount price of 10.00 (January 1)
Item A has Quantity of 100 with amount price of 11.00 (January 2)

What the computation does is sum the quantity and sum the Amount price and it will have the result of 6300.00

What I need is, it will multiply first then sum. It should have a total of 3100.00.

Computation in report is
=Sum(([Quantity] ForEach([Turnover].[Branch Name];[Item ID];[Price])*Sum(ToNumber([Price])) ) ForEach([Turnover].[Branch Name];[Item ID];[Price]) ) ForAll([Turnover].[Branch Name];[Item ID])

It works if I use option per item but if I choose All items. It has #Error.

Am using attached file for filtering.



Need help.
Back to top
wubertatwork
Principal Member
Principal Member



Joined: 19 Jan 2011

Posts: 173
Location: New York, NY


flag
PostPosted: Thu Mar 08, 2018 5:46 pm 
Post subject: Re: #Error Issue

Could you post a spreadsheet with sample data?

In each row of your data, is there a field that is just a variable defined as the Price x Quantity? That is, without using ForEach?

Why is ForEach being used?
Back to top
aileen.tiu
Forum Member
Forum Member



Joined: 29 Jan 2018

Posts: 2



PostPosted: Tue Mar 13, 2018 9:58 pm 
Post subject: Re: #Error Issue

Hi,

Thank you for replying. We have already solved this problem by adding a column on our ETL.
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Building Reports -> Web Intelligence  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0292 seconds using 17 queries. (SQL 0.0022 Parse 0.0009 Other 0.0261)
CCBot/2.0 (https://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo