BOB: Business Objects Board
Not endorsed by or affiliated with SAP

Register | Login 

Follow BOB on Twitter! 
Follow BOB on Twitter! (Opens a new window)  

General Notice: Upcoming Events: PGHBOUG: Aug 23.

Webi 4.2 - Query on query - object does not exist WIS 10888


 
Search this topic... | Search Web Intelligence... | Search Box
Register or Login to Post    Forum Index -> Building Reports -> Web Intelligence  Previous TopicPrint TopicNext Topic
Author Message
norty303
Forum Associate
Forum Associate



Joined: 19 Mar 2003

Posts: 617


flag
PostPosted: Thu Sep 14, 2017 5:32 am 
Post subject: Webi 4.2 - Query on query - object does not exist WIS 10888

I'm having a test with query on query functionality.

The intentions is for users to be able to upload lookup lists of IDs, and then run a report to obtain further details about the IDs from the DB

So I can import a list of IDs from an Excel data provider, refresh and see the values in the column (Dimension, number)

I then create a Universe data provider and set a condition where [PersonID] in list [ID column from Excel DP]

[PersonID] in the Universe is defined as Dimension, Number

All simple enough, however upon refreshing the report I get a WIS 10888 IES 10888 error.
"A condition on an object refers to an object in another query that does not exist"

Clearly the object does exist, as I can see it in the Excel data provider screen and manipulate its parameters, I can confirm the name is correct, and I can see the data in the report.

I can't find many references to 10888 error, so guess this isn't too common.

_________________
Production: Win7 client, Source DB: SQL Server 2008 to 2012, Server OS: Win Server 2012, SBOP 4.2 SP3 Patch 2
Back to top
Nick Daniels
Forum Aficionado
Forum Aficionado



Joined: 15 Aug 2002

Posts: 14061
Location: England


flag
PostPosted: Thu Sep 14, 2017 5:47 am 
Post subject: Re: Webi 4.2 - Query on query - object does not exist WIS 10

I have never seen that error. Is it to do with the order of the queries, e.g. the universe query running before the Excel query?
Back to top
norty303
Forum Associate
Forum Associate



Joined: 19 Mar 2003

Posts: 617


flag
PostPosted: Thu Sep 14, 2017 5:50 am 
Post subject: Re: Webi 4.2 - Query on query - object does not exist WIS 10

Nope, I've tried constructing the report with data providers in both positions, same results.

I have full control over application and folders, so not a rights issue (I wouldn't see results)

If I amend the name of the ID Lookup column in the Excel DP, it changes in the where clause in the Universe DP, so it is clearly aware of the object pre-query runtime.

_________________
Production: Win7 client, Source DB: SQL Server 2008 to 2012, Server OS: Win Server 2012, SBOP 4.2 SP3 Patch 2
Back to top
nickep
Forum Member
Forum Member



Joined: 30 Jan 2018

Posts: 1



PostPosted: Tue Jan 30, 2018 9:15 am 
Post subject: Re: Webi 4.2 - Query on query - object does not exist WIS 10

I was facing the same issue today, and fixed it by removing special characters from the spreadsheet in my Excel Document. Previously, there were parentheses in the column name. It was also the same name as the object that was being filtered in the other data provider. So maybe one of either removing special characters, or naming it something different than the dimension being filtered, solved the problem.
Back to top
Display posts from previous:   
Register or Login to Post    Forum Index -> Building Reports -> Web Intelligence  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT - 5 Hours
 
Jump to:  

Index | About | FAQ | RAG | Privacy | Search |  Register |  Login 

Get community updates via Twitter:

Not endorsed by or affiliated with SAP
Powered by phpBB © phpBB Group
Generated in 0.0304 seconds using 17 queries. (SQL 0.0031 Parse 0.0009 Other 0.0263)
CCBot/2.0 (http://commoncrawl.org/faq/)
Hosted by ForumTopics.com | Terms of Service
phpBB Customizations by the phpBBDoctor.com
Shameless plug for MomentsOfLight.com Moments of Light Logo